3

I have these modules installed with Drupal 7:

  • search_api

  • search_api_solr

  • search_api_autocomplete

There is a view configured for search results with exposed full-text search filter, based on the index in Solr set up via Search API. The view is working well, however autocomplete function isn't working at all, no glimpse of it present. Are there any special settings for autocomplete that may need to be activated for the view?

  • I have this same problem with same setup. When I go to the Autocomplete tab on my search index, I see my search view listed, but there are no controls to enable or configure the autocomplete. – Giles B Feb 4 '16 at 23:43
1

The README.txt file in the search_api_autocomplete module provides the following information:

  • Necessary setup

After having installed and enabled the module, you have to do some administrative steps to activate the autocomplete functionality. Autocompletion can be enabled and configured for each search separately.

To activate autocompletion for an index's searches, go to the index's „Autocomplete“ tab. There, you see all available searches for the index and can enable (and afterwards configure) autocompletion for each of them. All fulltext key fields on the searches should then become autocompletion fields.

  • It also goes on to say that there is a per search page permission that you need to set. I know this is an old question and answer, but I've done both of those things and have the same issue as OP. – UltraBob May 25 '16 at 14:59
0

I finally found the answer, and I'll share it here in case it helps someone. As @controla says, the help says you need to go into the autocomplete tab in your index settings, and enable the search for your view. It also says that you need to go into the permissions and choose which roles have permission to use autocomplete on the search. The thing that was missing for me is back on the search index autocomplete tab.

After enabling autocomplete for your search view, you need to click edit on the autocompletion index you've enabled and choose the display to enable autocomplete for. Mine was set to master by default, and not page as I needed it to be.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.