2

Maybe I am trying to do something simple and I am just blind, but after a day of hard work I am desperate...:

  1. I have view, created using Views 3 module, with source in index of Search API module
  2. I have Profile two custom fields on User Entity, named "Name" and "Surname".
  3. I am using two "Search: Fulltext search" exposed filters in View, grouped using AND. The first with "Contains all of these words" and the second with "Contains none of these words".
  4. I have user with "Name" = Vysakh, "Surname" = Babu

Now:

  • When is in first "Search: Fulltext search" exposed filter with rule "Contains all of these words" written "Babu" (without speech marks), it founds his profile. Great.

But:

  • When is in second "Search: Fulltext search" exposed filter with rule "Contains none of these words" concurrently written "Vysakh" (without speech marks), instead of excluding his profile as well (thus showing empty result), view shows all the profiles, except Babu Vysakh...

Any ideas why and what can I do?

I tried all combinations of exposed filters, put them to different groups, switch from "Search keys" to "Search filter"... No luck.

1

There is actually a bug in Search API 7.x-1.8.

The full-text views' filters handler is able to use only one exposed filter (the last one in stack, the previous instances are overwritten).

While it was a LOT of hacking in the Search API module, the simple answer is: you can use only one exposed Search filter in Views with Search API 7.x-1.8 without extensive PHP coding.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.