0

I had a Drupal 6 site on a server that I've made a local copy of using Backup & Migrate. I've now upgraded this site to Drupal 7 on my localhost. When I try to move this to a server (or, as I've discovered, a new installation of D7 on localhost) I get the following errors once I run update.php

Error message

  • Notice: date_default_timezone_set() [function.date-default-timezone-set]: Timezone ID '0' is invalid in drupal_session_initialize() (line 273 of /Users/username/Sites/sitename/includes/session.inc).
  • PDOException: SQLSTATE[42S22]: Column not found: 1054 Unknown column 'source' in 'field list': SELECT DISTINCT SUBSTRING_INDEX(source, '/', 1) AS path FROM {url_alias}; Array ( ) in drupal_path_alias_whitelist_rebuild() (line 380 of /Users/username/Sites/sitename/includes/path.inc).

The website encountered an unexpected error. Please try again later.

Uncaught exception thrown in session handler. PDOException: SQLSTATE[42S22]: Column not found: 1054 Unknown column 'ssid' in 'where clause': SELECT 1 AS expression FROM {sessions} sessions WHERE ( (sid = :db_condition_placeholder_0) AND (ssid = :db_condition_placeholder_1) ) FOR UPDATE; Array ( [:db_condition_placeholder_0] => Hz-vcoMFEI-tL3Tw55qLQG6kNqXmB2pziLRC1SMQVYw [:db_condition_placeholder_1] => ) in _drupal_session_write() (line 209 of /Users/username/Sites/sitename/includes/session.inc).

No idea what's going on as the upgraded D6-D7 original site is working perfectly - it's when I try to migrate it to a server that it all seems to break down.

Any ideas?

  • What do you mean by "a new installation of D7 on localhost"? Did you restore from Backup and Migrate to D7? – Kari Kääriäinen Nov 19 '13 at 13:36
  • I installed D6 on localhost, ran backup and migrate, updated to D7 and then tried to migrate to a a server - then I got these issues. – Allan Nov 19 '13 at 19:36
  • 1) By migrating to a server you mean moving as in ftp:ing or similar? 2) There is a contradiction in your question between "or, as I've discovered, a new installation of D7 on localhost" and "upgraded D6-D7 original site is working perfectly". So were there errors on localhost or server, or both? – Kari Kääriäinen Nov 19 '13 at 19:51
  • 1) Yes, FTP. 2)I was having issues moving to the server so tried to move it to another (new) DB on the localhost - I had the same issues on both. – Allan Nov 20 '13 at 14:20
  • I'm just trying to understand what exactly did you do to not get a working copy of your site that was working on local host and you just moved it to different database? – Kari Kääriäinen Nov 20 '13 at 22:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.