0

I want to upload .dcm image format file into Drupal7 article, but it's not allowed.

Suggestions about how to get this to work?

  • What kind of field is it? – Mołot Nov 20 '13 at 9:04
  • This is an image field – devjohn Nov 20 '13 at 9:06
  • .DCM files are not recognised by any browser as an image, so they can't and won't be displayed as such. The image field rightly doesn't allow you to upload a non-image file as an image, as it would be considered a bug. There's nothing you can do to 'fix' this I'm afraid, short of convincing the major browser vendors to implement the feature. – Clive Nov 20 '13 at 9:30
  • It is still a relevant question. For example, several browsers have some support for svg files, but Drupal doesn't allow that extension either. – Ursula Nov 20 '13 at 19:14
1

Unfortunately, it is not possible to allow image extension that cannot commonly displayed by a browser. You would have to use a filefield instead.

This has been discussed at:

https://drupal.org/node/1081060

https://drupal.org/node/1014816

And for D6 at:

https://drupal.org/node/515152

  • All above urls are not working, please check. Yes, i hav got these urls by google search, but they are not working. – devjohn Nov 20 '13 at 9:04
  • Hmm, the urls are working for me in different browsers. Do not understand why they are not working for you. – Ursula Nov 20 '13 at 14:40
  • I have tried them on chrome, mozila, ie but still these urls are not working... – devjohn Nov 21 '13 at 10:35
  • Can you be more specific? Are you getting to the host drupal.org but not to the individual pages, and get an error code? Are you having issues with https? Are you not finding the host? – Ursula Nov 21 '13 at 14:02
  • drupal.org is working, we can download any module... but not able to see these page.. we are getting error Sorry, 122.162.150.42 has been greylisted by http:BL. You may try whitelisting on drupal.org/httpbl/whitelist. – devjohn Dec 4 '13 at 11:54
0

You can set allowed file types at the field settings page of that image field.

Go to admin/structure/types/manage/article/fields/field_image and add the file extension to the comma separated list of allowed file types.

  • I have do that. But still its not include .dcm extension. – devjohn Nov 20 '13 at 5:47
  • 1
    This approach works for file fields. For image fields, Drupal restricts extensions to a few that can get displayed in most browsers. Unfortunately, Drupal 7 doesn't issue a warning when the administrator adds an additional extension to the form quoted above. – Ursula Nov 20 '13 at 19:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.