1

I have been using Views module to render Node's Full content (using unformatted list of fields!). Seems that was not such a good idea.

Now when I preview the Node, I see the Teaser and Full content Entity view modes (instead a View with fields). So the actual problem is these teasers and Full content are not themed the way my View is.

Is there any workaroud except rebuilding the whole thing in Display Suite module?

THX!

closed as too broad by Mołot, Free Radical, monymirza, Letharion, niksmac Dec 19 '13 at 5:21

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Yes, for sure there is ;) But that's all the answer we can give you until you will tell us how you configured views to take over your nodes. And what does it mean "I cannot"? Please tell / show us what exactly happens when you try. – Mołot Nov 22 '13 at 8:56
  • @Molot the thing is I have been using the Unformatted List of Fields (instead Full posts/teasers) for building my View. Now when I preview the Node, I see the Teaser and Full content Entity view modes (instead a View with fields). So the actual problem is these teasers and Full content are not themed the way my View is. Does that make any sense to you? – Antonio Nov 22 '13 at 15:00
  • Please edit to provide details. Details in comments may easily be overlooked or die in a comments purge. – Mołot Nov 22 '13 at 15:02
0

The solution was to rebuild the whole thing in Display Suite module. Views (when using Unformatted List of Fields) cannot render teaser and Full content in node's preview!

Not the answer you're looking for? Browse other questions tagged or ask your own question.