1

I have a field in my view and I have rewritten the result ( p align="left" [field_about_us_read_more] ) and also check the "Output the field as a link". in styling setting section, "Customize field HTML" is "None" and "Customize field and label wrapper HTML" is "DIV" the html code generated is like this:

<div>
    <a href="/www.com/test"></a>
    <p align="left">
        <a href="/www.com/test"> read more </a>
    </p>
</div>

How can I get rid of the first anchor link? and how to add extra html element in the " styling setting ".

TNX

0

Remove check from "Output the field as a link" and then in rewritten the result put this

<p align="left">
        [field_about_us_read_more] 
    </p>

or if not work try something like this (I mean in output use tag )

   <p align="left">
 <a href="/www.com/test">[field_about_us_read_more]  </a>

        </p>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.