1

I've tried entering:

error_reporting(E_ALL);
ini_set('display_errors', TRUE);
ini_set('display_startup_errors', TRUE);

at the beginning of my index.php file (after begin php tag and it hasn't done anything. When I run cron, it comes back and tells me that everything is ok.

Here's a brief overview of things that have transpired today:

  • I updated my views modules and made a database backup (i have no idea how to restore from this, btw)
  • I updated to core .24
  • I ran cron andfixed errors concerning .htaccess files. I followed this tutorial: https://drupal.org/SA-CORE-2013-003
  • I turned off error reporting (cause it's a production server: www.jcoledesign.com is the address)
  • All hell broke loose. At first it stopped loading some images, then it stopped loading all CSS, this is likely due to caching
  • I added the above code to my index.php file
  • I cleared cache, went back and tried to replace my .htdocs files with something more simplistic and still no go.

    I'm running out of ideas and nothing I try from here or google seems to work.

Please help and thanks in advance!

  • Did you also run the update.php? – Елин Й. Nov 25 '13 at 7:06
  • Too many things changed at a time. Can you tell us exactly between which steps site stopped working? I guess turning error reporting off wasn't the trigger and it must have happened earlier? Can you restore from backup and then try, testing step by step? And can you access server's error.log ? – Mołot Nov 25 '13 at 8:08
  • When I try to run update.php it just gives me a blank screen. I'm guessing that it's something to do with a server call. – architarious Nov 25 '13 at 18:55
  • I'm guessing that messing with the htaccess files is what screwed it up, cause it seemed like it stopped uncaching things afterwords. I had a WSOD problem earlier when I first installed and a server admin from my hosting company said he fixed it by changing my htaccess files. I reviewed some of the changes he made and it looks like he just added SetHandler Drupal_Security_Do_Not_Remove_See_SA_2006_006 and commented out Options +FollowSymLinks I tried remaking these changes but it was to no avail. – architarious Nov 25 '13 at 19:03
1

I figured it out!

The .htaccess file in sites/defaults/files/ CAN NOT include Deny from all

The tutorial I referenced earlier mentioned that /temp/.htaccess should have this included, but it didn't say that if you included it in other files that it would crash your site.

As a side note: It would be great if there was a basic tutorial out there for .htaccess files so that I can get an understanding of everything that's going on here without having to spend months/years learning everything else associated with hosting a drupal website completely inside and out.

  • 1
    There are tutorials on htaccess files all right. My google search results: 1 2 3 4 (randomized order). – Mołot Nov 26 '13 at 11:55
  • I just found out the same issue. It was because some of my theming files are located in sites/default/files. So most of the css stopped working. After removing 'Deny from all' from the .htacess everything went back to normal. Now, is it mandatory to have 'Deny from all' to get on the safe side? – Volker Nov 26 '13 at 13:15
  • Yes, you should have it in /temp/.htaccess , but apparently not in /defaults/files/ since it kills everything. – architarious Nov 26 '13 at 17:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.