2

I have upgraded a D6 to D7 site on my localhost. After upgrade I can login using admin credentials as per usual. I have disabled Clean URLs and I see that users are in detabase. Actually all works well however when I try to log in to a user account, I get:

The website encountered an unexpected error. Please try again later

I get this error also, when I create a user from admin panel. I tested a lot of suggestions but none helped. So appreciate your hints.

  • 2
    Well, I found a solution: as per stackoverflow.com/a/19113091/727695 I added some description to error and figured out that messaging module causes the problem. I disabled messaging, and could login afterwards – alfish Nov 25 '13 at 4:30
  • post it as answer and include the essential part of that link. – Bala Nov 25 '13 at 5:21
  • @Bala: the answer added – alfish Nov 25 '13 at 6:01
5

To figure out what was the problem, thanks to this post I opened include/error.inc

and replaced

print theme('maintenance_page', array('content' => t('The website encountered an unexpected error. Please try again later.')));

with

print theme('maintenance_page', array('content' => t('The website encountered an unexpected error. Please try again later.'.$fatal.' '.var_export($error,true))));

The new command prints out some useful info that can be used to debug. In my case, it turned out that messaging module caused the problem. I disabled messaging, and could login afterwards.

Note: before going to production, switch back to original error.inc, since the error outputs can be a gift to attackers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.