0

I have a view called Profile that displays some of the user fields. Amongst these is a Name field (field_name). I'd like to hide this field except for the administrator and the user himself/herself. I installed the Field Permissions module, wich nicely gives me the opportunity to mark the field as private. When this is checked, the Name's value disappears in my Profile view, but the according label is still there - and that's not very nice.

How can I hide the label aswell?

1 Answer 1

2

On the Name field's edit config popup, remove the text from the Label field and disable the label checkbox; expand the Rewriting section, and paste in the label followed by the name field's substitution pattern.... it will look something like this Name: [field_name]. Finally, ensure the option to disable rewriting when field is empty checkbox is checked.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.