0

i setup a map with openlayers, geofield, addressfield and geocoder.

I added a geofield to a node, with openlayers as the widget type, and use geocoder to get the geocode from addressfield.

when editing, user press the Find using Address field button and the map display with the marker if found.

the question: how to center the marker? If i set the zoom level higher (in Center and Bounds setting of open layer), the marker will not be shown (out of the visible map area).

  • I still need help on this, let me know if the question is not clear. – Kent Nov 29 '13 at 4:26
0

you need to enable placeholderlayer in openlyers map with a marker of your choice. and then in behaviours you need to zoom to layer and enable placeholder layer and save.

  • i couldn't make it work.. Can you please elaborate more? Thanks! – Kent Sep 17 '14 at 8:15
  • I am not clear with your requirment please elaborate more. – harsh_behl_0007 Sep 18 '14 at 8:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.