1

I've been trying to install Open Atrium for at least 6 hours and cannot find a solution. There seems to be a permissions problem…

Here's where I'm at: I successfully installed a Ubuntu VM, and installed Drupal 6. I then downloaded Open Atrium, copied its contents into the example.php folder. I then went to the default folder and changed the settings file to settings.php, etc. Install Atrium launches through Firefox, but then says:

Forbidden

You don't have permission to access / on this server.
Apache/2.2.16 (Ubuntu) Server at example.dev Port 80

Update:

I installed everything using the drush commands per quickstart tutorial. I created the example1.dev folder, then replaced its contents with Open Atrium. I then renamed the Default.install.php file to install.php, and created a files folder inside default.

I'm not sure why I'm having this problem, but it looks like a permission issue with the file folder. I can't figure out how to open up read/write permissions through Ubuntu. Any ideas?

I followed these directions verbatim, and wiped out the appliance and started over a few times as well. I'm at a loss. I think if I knew how to open permissions to Apache I'd be all set. Any ideas?

3

You said you downloaded Drupal, then downloaded Open Atrium?

Open Atrium is a specialized version of Drupal, you install it standalone.

  • 1
    That is correct: Open Atrium is a patched version of Drupal that contains all the Drupal files; the only difference is that some files have been patched to speed up Drupal in some circumstances. You don't download Drupal, and then Open Atrium. – kiamlaluno Mar 18 '11 at 7:50
2

user581 I don't think OpenAtrium is your problem. I think you are just installing it incorrectly. Did you follow the instructions here?

https://community.openatrium.com/documentation-en/node/2428

1

Does not seem like a drupal issue at all. There is some documentation on what permissions drupal needs in order to run, the key part being:

All the Drupal files (eg .php, .module, .css, .theme and images etc) will need to be able to be read by the webserver account. The 'files' is generally the only directory will need to be writable by the webserver account.

So ensure that the webserver user (normally www-data on Ubuntu using apache) has read access to the PHP files

UPDATE:

If you want this issue to be resolved by the community you will need to give me information, e.g.

  • What distro and version of linux
  • Version of apache
  • Are you using mod_php or fastcgi
  • The webserver user and group
  • current permissions (e.g. 640 for PHP, 770 for files dir etc)
  • current user and group owners of the drupal installation
  • Are you name-based virtual hosts or IP based?
  • If you place a plain info.php file in the webroot with

    <?php phpinfo(); ?>

in the contents - can apache read this?

  • What about if you chown www-data:www-data info.php - does this resolve the issue?
  • What about if you chmod 750 info.php - does this resolve the issue?

You probably should also refactor your question to remove open atrium as this is simply a distribution of drupal, at the moment if you will have troubles running any PHP files (i.e. drupal is not the issue here).

  • Yes, it does seem like a permissions issue. I was able to set read write permissions for the settings.php inside my default folder by right clicking file, properties/permissions > set to read+write. – Ramanonos Mar 17 '11 at 23:31
  • Requirements problem The following error must be resolved before you can continue the installation process: The directory sites/default/files is not writable. An automated attempt to create this directory failed, possibly due to a permissions problem. To proceed with the installation, either create the directory and modify its permissions manually, or ensure that the installer has the permissions to create it automatically. For more information, please see INSTALL.txt or the on-line handbook. – Ramanonos Mar 17 '11 at 23:32
  • Still very stuck... I try to set the files folder permissions to read+write, but it just defaults back to the "line" when I save permissions. What's going on? – Ramanonos Mar 17 '11 at 23:34
  • Just had to change permissions chmod 777. Thanks all – Ramanonos Mar 18 '11 at 22:23
0

In your Apache configuration, are both the following lines included?

AddHandler php5-script .php
DirectoryIndex index.php

The You don't have permission to access / error will be shown if the DirectoryIndex line is missing or not set to include index.php.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.