0

I recently started working on adding translation to my Drupal 6 site. I am using the modules 1)Translation Manager 2)i18n 3)Language Switcher Dropdown

It seemed pretty straight forward to me. I read the multilingual drupal guide http://drupal-translation.com/content/setup-multilingual-site

I sent all my content type/strings to one of my translators (using local translators). My translator translated one of our pages for a certain content type, and finished the translation.

The only problem is that the content type she translated has both the english and the translated version showing up on the same page.

Here is the page http://caribbeanenvirolaw.org/ngos The duplicated page is "Jamaica Environment Trust (JET)

I notice when I go to the french JET page the Language dropbox shows "Francais", and when I go to the english JET page the language dropbox shows "English".

I would like the french translated pages to only show up if the language select box shows French, and have the English pages be the only ones that show up if the language selectbox is set to English.

The NGO page that is showing both french/english JET pages is a view, but I couldn't find anything in the views section regarding translation and only showing the current languages pages.

Little help?

***Update****

enter image description here

The page in the picture is a drupal "view". The content type "Belize - ....." is in English, and has been translated to spanish/french. Those spanish and french translations show up as separate content type's on the drupal page (the view).

Since the language dropbox is set to "English" you would think that it would hide the spanish/french versions, but it is not.

enter image description here

For each of the "Belize - ...." content types (english, french, spanish), I tried multiple configurations to get drupal to leave out language content that is not for the language currently selected. In the last image you see I'm setting the url to be "belize". I used this same value for each of the translated contents.

Scrolling over the links for each translated "Belize - ...." content shows

1)English url =  caribbeanenvirolaw.org/belize
2)Spanish url =  caribbeanenvirolaw.org/es/belize
3)French url =  caribbeanenvirolaw.org/fr/belize

When I open, for example the spanish translation of belize page from the view, I see enter image description here

Notice that the language dropbox now say Espanol, meaning it is recognizing that it is a spanish page, but still it shows the spanish/french translations (as well as english) on the view (first image) no matter what the Languages dropbox has selected.

Keep in mind that I have also tried to not edit the url path's manually (leaving them blank). I get the same results from doing it that way too.

1

ANSWER

Heya, found the answer. The view needs to have the correct filter added to it.

Go to Adminstration->views Click the plus button next to the Filters section.

enter image description here

You will then see a list of filters pop up. Find "Node Translation: Language. Add it. You will then see a section that asks what you want to do with the filter.

enter image description here

Choose "Is One Of: Current User's Language" That is it. Your views should now NOT contain multiple translations of the same document.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.