1

I just installed Drupal 6 (Don't ask why) from a fresh install (Version 6.29). I followed the install steps, created an admin user, set the correct time zone, etc.

But when I login and attempt to proceed to the admin panel, I get Access denied You are not authorized to access this page. I have read about this issue many other places, and have attempted many solutions, but none seem to work for me.

I noticed that there is nothing in the sessions table of my MySQL database for this drupal install (but there is data in other tables). I think that this has something to do with it, but ti could be that there is info in the table, but it is immediately removed due to a session/cookie issue.

I have repeatedly removed all my browser cookies each time I have tried a solution. I have tried many solutions on drupal.org, many of which have been also referenced on other sites, but none have worked.

OS: Mac OSX 10.9 (Mavericks)

Web Server: Apache/2.2.24 (Unix) PHP/5.4.17 mod_ssl/2.2.24 OpenSSL/0.9.8y DAV/2 Server at XX.XX.XXX.XXX Port 80

Not using SSL for this drupal install.

closed as too broad by kiamlaluno May 22 '15 at 14:53

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

1

It may be that your cookie domain is not set correctly, this is a known cause of Access Denied errors when logging in, and it might be worth removing cookie domain info from settings.php and see if that works, and go from there.

0

Running Drupal 6 on PHP 5.4 is unreliable at best. PHP 5.2 is recommended, 5.3 could work, but you would probably run into issues with contributed modules.

That said, you could try what has been outlined here, basically:

  1. Create a temporary session.
  2. Clear all caches.
  3. Updated php.ini with correct timezone info (and reload Apache settings).

Cheers,

  • None of that helped. When i created a temporary session with drush and used the link it generated, I got a access denied message after I got redirected to /?q=user/1/edit. Since I can't login to clear the cache, I used drush to clear all the caches on my site. This did not help either. My php.ini has the correct timezone. None of these things seemed to help :( – Santa Claus Nov 28 '13 at 15:17
  • Sorry to hear it didn't work. My other suggestion would be to check the error logs and try to figure out and solve the root cause. You should also be able to install 5.2 alongside 5.4, but it might just be easier spin up a VirtualBox instance or upload the site to a server running 5.2. – enzipher Nov 28 '13 at 19:01
0

It is probable an issue with a cookie.

If you are using chrome (1) go to : chrome://settings/cookies.

(2) paste the link of your website to the search bar.

(3) delete the session cookie.

(4) Try access your site again..

Not the answer you're looking for? Browse other questions tagged or ask your own question.