0

I'm setting up a site with cartaro and I've installed the openlayers editor module but it doesn't seem to be working. I manually downloaded the ole js library as described in the installation instructions for the module, and I can access sites/all/libraries/ole/ole.min.js from my browser but it doesn't seem to be loaded when I open a page. There are no errors showing up anywhere (i.e. no JS errors and nothing in the Drupal logs), although on a previous test site I got the following error when opening the configuration page:

Notice: Undefined index: version in ole_requirements() (line 22 of /var/lib/openshift/528c88a2e0b8cd4d7d0000a4/app-root/runtime/repo/php/sites/all/modules/ole/ole.install)

As far as I can tell everything is set up correctly, i.e. I have installed and activated openlayers, openlayers-editor, libraries, so I have no idea what else to check.

  • Have you inspected your HTML output? Is that file ever loaded? And of course I hope you disabled JS aggregation for testing purposes. – Mołot Nov 29 '13 at 8:13
  • @Mołot No, ole.min.js isn't loaded and yes, JS aggregation is disabled. – aquavitae Nov 29 '13 at 8:21
  • Well, if this JS is not mentioned in your HTML output, it simply cannot work. Probably a bug in a module, that should be posted in module's issue queue. – Mołot Nov 29 '13 at 8:23
  • 1
    @Mołot Yes, I realise that the problem is in the module, not the js. I've posted a bug report already, but nobody else seems to have the problem. I've tried a couple of test sites and have the same issue on every one, so it looks like something I'm doing wrong. – aquavitae Nov 29 '13 at 8:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.