0

I have installed Advanced Form Block (AFB) in a Drupal 7 site.

At first the AFB settings didn't show. But after applying the patch from issue 1863852 that got resolved. I can now create blocks, but in my block configuration form no fields are showing up. I am not getting options like in this image:

enter image description here

Basically I have a content type add content form that I was hoping to be able to split up into different blocks. I created an add type of block but when I go to that blocks configuration page I don't get any options beyond the normal options (no field selection options are presented to me).

Any idea why?

Infact the block isn't displaying at all, and I tried using different content types. When I go to the block configuration and save it I also get these notices:

enter image description here

I have been and am continuing to use Form Block.

Thinking about it those notices appearing would seem to be part of the problem as they would hint that the fields aren't being found and therefore cannot be displayed.

9
  • 3
    This question appears to be off-topic because it is a bugreport for AFB module, and should be posted in module's issue queue.
    – Mołot
    Dec 4, 2013 at 11:38
  • Have posted it there too but was hoping to possibly get the advice of the drupal community here. It is reported that there are 363 users of the module and yet the issue queue doesnt contain any similar references so it might be simply my issue. Hoping someone here might have some knowledge on the subject. Dec 4, 2013 at 12:07
  • Everyone who is able and willing to work on bugs in this module probably already keeps track of it's issue queue. And in the help center you will find a specific rule against posting bugreports here. Solving it here would deprive maintainers and other devs on drupal.org from their chance to participate. What worse, we hope to be a knowledge repository. So questions that by very nature gets useless once answered are not welcome.
    – Mołot
    Dec 4, 2013 at 12:11
  • I dont understand how any question that gets answered suddenly becomes useless. If it helps someone who has the same problem further down the line how is it useless. And once again who is to say it is a bug in the module? I'm not sure it is so I'm casting a wide net to try to figure out why it is happening. My point being that if it has not already come up in the issue queue that it might not be a bug in the module. Dec 4, 2013 at 12:14
  • It becomes useless because when the bug is fixed, no one is ever going to ask how to fix it.
    – Mołot
    Dec 4, 2013 at 12:17

1 Answer 1

1

It seems formblock and afb (advanced form block) conflict with each other. On my development site i disabled and uninstalled formblock and then all aspects of advanced form block worked as it should. I do not want to do this to my production site because I am unsure of whether I will switch due to the work invovled

1
  • is this a bug in either module? I'm not sure about the nitty gritty of modules conflicting with each other. Dec 4, 2013 at 12:46

Not the answer you're looking for? Browse other questions tagged or ask your own question.