0

I recently upgraded to 7.7 because of the security updates, but now, when I try to add content there is no body field... and when I go check the module list I see this message on top of the list.

Notice: Undefined index: module in _field_info_prepare_instance_widget() (line 382 of /var/www/gisele-drupal/modules/field/field.info.inc).
Notice: Undefined index: module in _field_info_prepare_instance_display() (line 350 of /var/www/gisele-drupal/modules/field/field.info.inc).
Notice: Undefined index: module in _field_info_prepare_instance_widget() (line 382 of /var/www/gisele-drupal/modules/field/field.info.inc).
[…]

Does anyone know what could be going on here, and how can I solve this?

  • You may want to use drupal's issue queue and not stack exchange for problems like this as describe in the FAQ. Did you review this issue queue node? drupal.org/node/1062142 – chrisjlee Aug 19 '11 at 17:33
2

Are you using OG? Because that could be causing the issue.

Things to do

  1. If OG is installed, but not enabled delete it.
  2. Clear Cache
  3. Update all modules up to their most recent versions
  4. Run Update.php (do whenever a module is updated or deleted)
  5. Uninstall Views and reinstall it

Issue about this problem here > http://drupal.org/node/1001060

  • not using OG. All modules and core are updated... the message no longer shows up but I still don't have my body field displayed – la_f0ka Aug 19 '11 at 15:50
  • your best bet is to check the issue que link above – nmillin Aug 19 '11 at 15:52
  • I did it Chris, hopefully I'll get a response but I am not holding my breath. – la_f0ka Aug 19 '11 at 21:43
0

Besides the core issue, there is also a problem with Entity Reference: http://drupal.org/node/1329354. I'd recommend doing some disabling (as suggested) to determine which of these bugs is the culprit.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.