7

I added couple of Text fields on a content type in Drupal; however, only the in-built "body" fields is WYSIWYG editor enabled. I am using FCKEditor as the WYSIWYG editor (installed under the Wysiwyg module).

How can I get WYSIWYG editor enabled on custom added field?

migrated from stackoverflow.com Aug 19 '11 at 16:43

This question came from our site for professional and enthusiast programmers.

  • check how is the WYSIWYG attached to the body field and copy it for other fields as well. it should be just one or two lines in javascript. – dusoft Feb 28 '09 at 19:45
7

If you are not wanting to make every single textarea an editor, FCKeditor under Drupal lets you choose exactly which fields will be WYSIWYG editors .. you need to configure (.../admin/settings/fckeditor/default) for "include" mode and list the node-type field IDs. You can even specify a simple vs normal toolbar. Quite flexible

9

Click Configure of your CCK field and choose Filtered text (user selects input format) under Text processing. This configuration will show input format selection you need to choose. As long as you configure properly your WYSIWYG module the editor will show.

  • Something like this can take days to figure ou if you don't know what you are looking for. Thanks. – cdonner Jan 22 '12 at 0:07
3

Yes! You can enable the WYSIWYG editor for every field that you add using CCK.

  1. Add and enable the WYSIWYG module.
  2. Configure the WYSIWYG module. You can use either CK EDITOR or FCK EDITOR.
  3. Go to Manage fields under Content types and configure each field. Enable filtered text under Text processing of Global settings.

And you're done!

2

I kept searching for this issue for about 6 hours and finally i found the reason, for your custom textarea field you must add this line, to use the default input format (Full HTML):

$form['format'] = filter_form();

be careful if you use this form element inside fieldset you must include this fieldset:

$form['donation-instructions']['format'] = filter_form();

I hope this will help you

1

Don't forget to check on the minimum rows setting. This was my problem... I had my field's rows set to 3 and my FCKEditor settings to minimum rows 3. I changed field's rows to 4 and it worked!

It doesn't seem to matter if I've set the field to Plain Text or Filtered Text - it works either way.

0

OK. I figured it out. I went back and edited the field definition: Changed the "Text Processing" value to "Filtered Text" from "Plain Text" so that the user can select input type.

0

I went round and round with this and finally saw the fckeditor setting in the profile settings (NOT the global one) that reads

Minimum Rows [ 4 ]
FCKeditor will be triggered if the textarea has more rows than entered here. Enter '1' if you do not want to use this feature.

And of course, in my field setup I had rows set to 4, so the darn editor never kicks in! I changed my field rows to 5 and woop! there it is!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy