0

Hoping all is well.. I have developed a personal theme and enabled it in a drupal installation. However static html doesn't show up at all.

I have used wysiwyg with ckeditor and enabled full html and still nothing shows up after saving. This happens with nodes and blocks. Only Plain text works and of course that doesn't implement html.

This problem's just began with this project. I have tried to create a fresh website and the problem prevails. I have even tried enabling garland (one of the default drupal themes) and i am still facing the same problem.

Has anyone faced a problem like this before?

4
  • did you inspect that the page using firebug? is actually content showing there, and not displaying because of some css issue? did you check that?
    – Cool
    Commented Dec 9, 2013 at 19:11
  • 1
    On the "fresh website," did you also enable WYSIWYG/CKEditor? I'd try leaving those disabled to just reduce the number of things that might be going wrong - and WYSIWYG can sure make things go wrong… Commented Dec 9, 2013 at 21:02
  • @ARUN firebug shows no content displayed just as no content is displayed on the node/block. When i try to edit the node/block, the content is actually there.
    – denomdub
    Commented Dec 10, 2013 at 5:51
  • @GarrettAlbright i have actually disabled the editors (uninstalled it as well) to try and narrow the problem down. I am still facing the same problem.
    – denomdub
    Commented Dec 10, 2013 at 5:53

2 Answers 2

1

Looks like it worked out after Upgrading Mysql (from 5.1.. to 5.5..) had php (5.4.17) now its 5.4.22 (guess there's no big difference there..). Thought i'd put it here incase anyone runs into such a weird problem in the future.

Thanks everyone for trying.. Really appreciate it!

0

enter image description here

make sure your Full HTML settings are as shown. As you see that there is no HTML, there is a strong probability that second option "Display any HTML as plain text" is enabled.

3
  • My settings are like they appear above. Still facing the same problem. Thanks though
    – denomdub
    Commented Dec 10, 2013 at 5:57
  • Can you please check how is the data stored in Database. Is it saved with HTML or not ? If HTML is saved, then it is problem with the rendering of the content. Commented Dec 11, 2013 at 6:25
  • I have checked and the data is saved as HTML in the database.
    – denomdub
    Commented Dec 11, 2013 at 15:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.