I have a slight issue in connecting Drush to my MAMP localhost DB. Already tried multiple solutions like changing host from localhost to, and editing MAMP files like this suggestion.

It seems my socket location is slightly different from most examples I see on the web, being var/mysql/mysql.sock rather than tmp/mysql.sock. I installed via homebrew, if that's helpful.

Super new to drush, and command line in general, so any help much appreciated. All file transfers (like dl) work fine, just anything DB related throwing an error. Thanks!

    PDO::__construct(): [2002] No such file or directory (trying to connect  [warning]
via unix:///var/mysql/mysql.sock) environment.inc:523
Command pm-enable needs a higher bootstrap level to run - you will need  [error]
to invoke drush from a more functional Drupal environment to run this
The drush command 'en views' could not be executed.                      [error]
Drush was not able to start (bootstrap) the Drupal database.             [error]
Hint: This may occur when Drush is trying to:
 * bootstrap a site that has not been installed or does not have a
configured database. In this case you can select another site with a
working database setup by specifying the URI to use with the --uri
parameter on the command line. See `drush topic docs-aliases` for
 * connect the database through a socket. The socket file may be wrong or
the php-cli may have no access to it in a jailed shell. See
http://drupal.org/node/1428638 for details.

Drush was attempting to connect to: 
 Drupal version        :  7.24                                          
 Site URI              :  http://default                                
 Database driver       :  mysql                                         
 Database username     :  root                                          
 Database name         :  DB_name                                
 Default theme         :  garland                                       
 Administration        :  garland                                       
 PHP executable        :  /usr/bin/php                                  
 PHP configuration     :                                                
 PHP OS                :  Darwin                                        
 Drush version         :  6.1.0                                         
 Drush configuration   :                                                
 Drush alias files     :  /Users/UserName/.drush/pantheon.alias 
 Drupal root           :  /Applications/MAMP/htdocs/landmark/landmark-l 
 Site path             :  sites/default                                 
 File directory path   :  sites/default/files                           
  • Did you just try installing drupal via the install.php file? Commented Dec 10, 2013 at 21:12
  • Yes, D7 is up and running on localhost, no issues there. The issue is solely around connecting Drush to that DB. Thanks for checking! Commented Dec 10, 2013 at 21:32
  • you also tried the symlink ? (like: ln -s /tmp/mysql.sock /var/mysql/mysql.sock)
    – rémy
    Commented Dec 10, 2013 at 22:51
  • Remy, yes, just tried that as well with no luck. Does the unix:/// in front of the socket path affect that? Commented Dec 11, 2013 at 0:19
  • The background for truly troubleshooting and arriving at the answer above is clearly explained over in this gem of a post: drupal.stackexchange.com/a/174128/3167 which is conveniently hidden away due to a non-generalized post title, so I'm sharing here for the next time I stumble upon this issue and forget exactly what to search for to find that post! Commented Aug 17, 2016 at 16:35

1 Answer 1


OK, finally got it working:

sudo mkdir /var/mysql
sudo ln -s /Applications/MAMP/tmp/mysql/mysql.sock /var/mysql/mysql.sock

Thanks to Remy for putting me on the right track, and This drupal.org post.

Seems it was that I needed to make a directory first... Rookie move.


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.