1

I accidentally removed the text formats like:

  • Full HTML
  • Filtered HTML
  • PHP Code

from admin > config > content authoring > text formats.

I want to get them back but couldn't find a way. I re-installed the third party editor (ckeditor) for wysiwyg and also reinstalled the wysiwyg module, but it didn't help.

3

You soudln't disable text formats on config > content authoring. Now you only can edit your site's database tables. Table "filter_format" has column "status" and rows with text formats names. Change values in "status" column to 1 for each format you want be enabled.

  • I changed their values form 0 to 1 in my database, but I cant find them in admin>config>content authoring>text format. What might be the problem? – maaz siddiqui Dec 12 '13 at 6:05
  • Hey, I got it working. All I had to do after that step was to clear cache by going to admin>config>development>performance>clear cache. Thanks a lot for your answer. – maaz siddiqui Dec 12 '13 at 6:14
  • Glad to help you – Nafscript Dec 12 '13 at 19:21
  • Thanks for this. Seems like if removing one of the 3 default formats has the potential to cause so much trouble that it should not be allowed to remove them. – squarecandy Feb 1 '15 at 0:47
  • @squarecandy Nah, what if someone only wants plain text? It doesn't make sense to have content types that you'll never use. That could have security implications. – mbomb007 Nov 6 '18 at 16:09
0

For Drupal 8:

  1. Export the configuration of the disabled filter
    (under /admin/config/development/configuration/single/export)
  2. Change the line status: false to status: true
  3. Import the configuration
    (under /admin/config/development/configuration/single/import)

After this, the previously disabled text filter will be listed under /admin/config/content/formats again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.