2

Ok, I also have the Better Exposed Filters module installed and enabled on this view, but this does not help. I have no control over the label of this exposed filter that is being grouped. There is no option to change the label on grouped items, only on single items.

What do I have to do to be able to change the label? Am using Drupal 7.24 and Views 7.x-3.7 and Better Exposed Filters 7.x-3.0-beta3.

Thanks to anyone who can help... right now it is showing the machine label in parenthesis next to the actual title of the field. I'd rather just have only the title of the field.

Here is what the settings look like for an exposed grouped filter to me:

part1 part2 part3

And here is what the filter looks like on the actual view:

front-end view display

How to get rid of the (field_department) text or change the label completely?

  • 1
    A similar issue and troubleshoot drupal.org/comment/7965583#comment-7965583, check the third comment. – Anoop Joseph Dec 13 '13 at 6:19
  • Not sure what he is talking about tabbed to the filter label field... There is NO FILTER LABEL field to tab to period! – Solomon Closson Dec 13 '13 at 6:28
  • Did you try to alter the exposed filter form with hook_form_alter()? – xurshid29 Dec 13 '13 at 6:35
  • I am kind of new to Drupal and don't really know how to do all of that yet... Where and how would I implement something like that? – Solomon Closson Dec 13 '13 at 6:43
  • Well I just disabled the label completely in views-exposed-form.tpl.php by removing the reference to it, however, it would be nice if I could figure out a way to just remove the reference to it for just that specific view. – Solomon Closson Dec 13 '13 at 7:04
2

Normally you can remove field machine name from the configuration itself as shown below, but seems like those portion is hidden from your screenshot. Please check those portion, also check this troubleshoot Can't set the label for an exposed grouped filter.

If still no help you can use hook_form_alter(&$form, &$form_state, $form_id) to change the label

enter image description here

  • Perhaps it is the Admin theme that I am using that doesn't make it show... will change Admin themes and see if that helps. – Solomon Closson Dec 13 '13 at 7:17
  • Yep, it was the Administrative Theme "Rubik" that I was using, it doesn't show anything but the "Allow multiple selections" checkbox and label in that area. When I switched to a different theme I can now see and edit the label. Thanks for your help though! – Solomon Closson Dec 13 '13 at 7:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.