1

I have strange issue. I have several node instances included part of the packaged feature XXX that service as test pages. These node instances have two fields - the default body and extra text field 'description'. When I install this feature for the first time on new Drupal site, everything works. If I roll back via Migrate_backup or physically dropping all tables, the second time installing the same feature all body fields is coming up empty and the extra field 'description' is not installed at all

There is no messages in the watchdog log. My current versions:

Feature 7.x-2.0
uuid_features 7.x-1.0-alpha3
fe_block 7.x-1.0-beta1 
strongarm 7.x-2.0 

I also tried this with newest dev versions of uuid_features, fe_block, strongarm, but the same issue

My solution is recreating feature with different name but its unnecessary extra work and time. Have you ever experienced this issue? How would you troubleshoot? Can i enable some kind debug mode for feature installation or any module for that matter? I may be just doing it wrong as this my first experience with Features module. Thank You

1

It turns out the feature is in 'overridden' state

drush fl name_on_feature

If I did revert

drush fr name_on_feature

Then that solved my problem but i am still puzzled. If I drop tables, then how is it detecting 'overridden' state. Does Features module has some local file cache used for handling states?..just thinking loud. To my understanding revert updates database according to the code of the feature.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.