0

I've installed the Wysiwyg module for Drupal 7, as well as the latest CKEditor, configured the settings, and yet it refuses to appear! I've gotten other editors to work but they're not as good.

I'm the only one using the site so I don't have to configure permissions right?

I would have thought this would be one of the simpler things to do in Drupal!

Any help greatly appreciated.

migrated from stackoverflow.com Aug 21 '11 at 11:37

This question came from our site for professional and enthusiast programmers.

  • 1
    Follow readme.txt of wysiwyg editor or use ckeditor module. – Nikit Aug 21 '11 at 1:04
  • I've tried both of those things – Mythical Fish Aug 21 '11 at 1:28
  • Somewhat OT, but if you are set on CKEditor, I'd use the CKEditor module instead of Wysiwyg. It's much better for CKEditor. – czervik Sep 15 '11 at 14:33
2

I thought the directions were quite confusing, so I agree that this should be easier. The problem is that you need two downloads, and one of them is a wrapper for the other.

Here's what I did that works on Drupal 7.7 and 7.8:

  1. Download CKEditor 3.6.1 from http://ckeditor.com/download
  2. Download CKEditor 7.x-1.3 from http://drupal.org/project/ckeditor
  3. Unpack CKEditor 7.x-1.3. This will create a folder called CKEditor
  4. Unpack CKEditor 3.6.1. This will create a folder called CKEditor2
  5. Move the contents of the CKEditor2 folder into the CKEditor subfolder of the CKEditor that was created in step 3. This subfolder should have a file called COPY_HERE.txt in it (Yes, I know this is confusing)
  6. Delete the CKEditor2 folder
  7. Upload the contents of the CKEditor folder to your /sites/all/libraries folder. If you've done this correctly, the Libraries folder will have ckeditor-rtl.css, ckeditor.api.php, ckeditor.config.js, a number of other individual files, AND a CKEditor folder that contains a number of files (one of which should be the all-important ckeditor.js)

Hope this helps. I wish it were simpler. (TinyMCE is easier to install.)

  • Thanks, that is essentially what I did to get it working, but for some reason had to move some files around within the "modules/ckeditor/ckeditor" directory. – Mythical Fish Sep 20 '11 at 18:16
3

Here are the steps that worked for me on Drupal 7.7

  1. Instal the WYSIWYG module and enable
  2. Download the latest CKEditor and unzip it in sites/all/libraries
  3. Go to configuration => wysiwyg and choose the editor for the input format (use it on the full HTML or PHP)
  4. Now you can edit and there you can choose under buttons and plugins what buttons appear
  5. When you create a content type don't forget to set the correct text format

btw a while back I had a problem where the WYSIWYG used the background from my site. I had to change the CSS settings, below buttons and plugins, and set it to use editor default.

  • Thanks for your answer, however this did not work for me - I eventually got it working with the CKEditor module. See this thread and read my answer if you are having the same issue. – Mythical Fish Sep 20 '11 at 18:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.