2

Strangely I cannot find this directory anywhere inside sites or files. There is only one in /var would that be it? I need to edit the .htaccess as it states in my reports. Also what ownership and permissions should this display?

Ok I found it in directory above /var and deleted it then created it again and set it as 755 permissions with apache ownership and placed security script in .htaccess as given in reports link.

Update: the .htaccess in files and tmp folders to create more security shut me out! I had to remove them. OKAY finally worked this out and why looking for tmp folder in first place! A status report glitch error for files and tmp folder saying needed to add security .htaccess file is BOGUS! it is a bug of some sort in 7.24 for my system Centos linux so my removing them was exactly what I needed to do after adding erroneous security updates.

  • Did you check where is your tmp directory in admin -> Configuration -> File System in your drupal system? – cayerdis Dec 14 '13 at 3:35
2

Look in your Drupal admin area at /admin/config/media/file-system

This will tell you where Drupal thinks it's tmp folder is currently set to.

Depending on your host provider you may or may not be able to write to that location.

The php-info report found on your Status Report page admin/reports/status can tell you where PHP's temp directory is defined to be on your system:

upload_tmp_dir no value

Using htaccess, or ini_set in settings.php you can tweak where the upload temp directory is for your Drupal installation if need be.

  • I access via ssh and it is in cd / the root of directory and now have changed to 777 permissions it is working again. my config is set to /tmp which also throws no errors – cea Dec 14 '13 at 3:51
  • Your answer is informative for locating the folder- thanks. is 777 ok for permissions and chown apache:apache? – cea Dec 14 '13 at 3:52
  • it would depend on your system. What it is your operating system? is it Fedora, Ubuntu, Centos? 777 is not a good number. – cayerdis Dec 14 '13 at 4:07
  • @CharlieBunt, you can but not need change it to 777, just change it to 755 work correctly . – Yusef Dec 14 '13 at 4:10
  • There is not one configuration that is correct for shared hosting. See the accepted answer this question to learn how to figure this out: What are the most appropriate users and permission levels for Drupal sites on shared hosting? – Free Radical Dec 14 '13 at 8:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.