3

Dursh works very well with my Drupal 7, but when I try running Drush on Drupal-8 directory it throws some error message,

$drush pm-list

Command pm-list needs a higher bootstrap level to run - you will need invoke drush from a more functional Drupal environment to run[error]
this command.
The drush command 'pm-list' could not be executed.                                                                                 [error]
A Drupal installation directory could not be found     

could anyone tell me the solution for this problem?

any help is appreciated. Thank you.

10

Which version of drush? https://github.com/drush-ops/drush#drush-versions has a nice table, but in short you need the master branch from github if you want to work with Drupal 8.

  • so it was version compatibility issue, my version was 4.5, i didn't really noticed that. Thank you sir. – shrish Dec 16 '13 at 2:35
  • Drush 7 works with Drupal 8. See also drupal.stackexchange.com/questions/85281/… – batigolix Dec 31 '13 at 12:47
  • Yes and master contains Drush 7 at this moment. – user49 May 30 '14 at 9:11
0

I have not used drush with drupal 8, but these errors are sometimes experienced with D7 if you run drush from outside a site directory (eg sites/mysite.com) if the 'default' site is invalid or not defined.

Is it possible this might be the case here?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.