0

I restored my site from the backup taken from another computer. Another drupal site is working fine in my machine, but this site which I restored from a backup is not working fine.

I am able to see the home page, front page but not any other pages of this restored site. when I click on links displaying 404 error (page not found).

When it is working for some other site, it has to work for other also. But I am missing some site specific configurations.

could any body please help me in this regard

  • clear your cache and check if it works. – Bala Dec 16 '13 at 10:02
  • unable to get to that configuration page also ... – Chella Dec 16 '13 at 10:03
  • And if you will use example.com/index.php?q=node/1 or example.com/index.php?q=admin what can you see? – Mołot Dec 16 '13 at 10:05
  • example.com/index.php?q=admin is working, but not index.php?q=node/1 – Chella Dec 16 '13 at 10:07
  • @Chella please answer @ (at) me next time. Maybe you don't have node 1 ;) It looks like your htaccess was not in backup, or if it was in backup, it wasn't restored. If it is there, diff it with Drupal's core htaccess from fresh download from drupal.org – Mołot Dec 16 '13 at 10:12
1

Looks like you have lost your .htaccess in the process. Download newest Drupal core from Drupal.org, extract it and put .htaccess in the root directoy of your Drupal. If this still does not work, and your .htaccess is ignored, go to official Clean URLs documentation, and find a section Server configuration for Clean URLs on a dedicated server, with httpd.conf - this should show you how to configure it properly.

| improve this answer | |
0

I tried in this way, I gone to mysite.com/index.php?q=admin/config/search/clean-urls

I turned off clean urls.. My site working now...!

| improve this answer | |
  • 1
    Pretty OK workaround, but not a fix for long run. – Mołot Dec 16 '13 at 10:45
  • why is it not a fix for long run?? – Chella Dec 23 '13 at 7:17
  • 1
    Because not having clean URLs is bad for business, it makes your site use ?q= in all addresses, and most people would mistype that, so you can't really put it on posters, flyers or product boxes. – Mołot Dec 23 '13 at 7:34
0

Hello its all about Clean URL enable to your site, so just got to

?q=admin/config/search/clean-urls

and turned off clean url

your issue will be sort out

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.