1

I am configuring search api and apache solr on my localhost. But it gives me the following error

An error occurred while trying to search with Solr: "400" Status: Bad Request: Bad Request{"responseHeader":{"status":400,"QTime":1,"params":{"hl.fragsize":"0","f.spell.hl.snippets":"3","hl.mergeContiguous":"true","qf":["tm_title^5.0","tm_body$value^1.0"],"hl.simple.pre":"[HIGHLIGHT]","f.spell.hl.fragsize":"70","json.nl":"map","hl.fl":"","wt":"json","hl":"true","rows":"10","fl":",score","hl.snippets":"1","start":"0","q":"\"test\"","hl.simple.post":"[/HIGHLIGHT]","fq":["((ss_type:\"article\") OR (ss_type:\"page\"))","index_id:default_node_index"]}},"error":{"msg":"undefined field ss_type","code":400}} .

on the site. The same error displays when I try to view the default node index.

And on the apache solr configuration page it displays the following error in logging.

org.apache.solr.common.SolrException: undefined field ss_type

I am using apachesolr 4.6 version.

EDIT

I have created the new server and when view that server at the top of the page this error displays;

You are using an incompatible schema.xml configuration file. Please follow the instructions in the INSTALL.txt file for setting up Solr.

  • try to remove all indexes and reindex them – xurshid29 Dec 17 '13 at 11:49
  • I am unable to click on the default node index link because it gives me the above error when I click on it therefore I am unable to remove all indexes and reindex them. – Ahmad Dec 17 '13 at 12:09
  • use this link: admin/config/search/apachesolr/settings/solr/index – xurshid29 Dec 17 '13 at 12:13
  • I am using search_api and search_api_solr modules not apachesolr module. – Ahmad Dec 17 '13 at 12:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.