0

The front end time shows as 3 hours behind the backend time of the same page. The correct time is the one on the backend. I set the time-zone correctly for the user and also the time show correctly in the "Administration » Configuration » Regional and language » date and Time" enter image description here

Here is the time that the page shows on the Backend (the correct time): enter image description here

And here is the time showing on the front-end (3 hours behind) enter image description here

And here is the code that I am using in the page template file:

`<?php print "Last Updated: " . format_date($node->changed, $type = 'medium'); ?>`

I am developing this Website locally on my machine (localhost). Any Ideas to get the time correct on the front end? Thanks.

  • You are using the same user when viewing the front/backend? – rreiss Dec 20 '13 at 17:49
  • Yes I am the only admin for this website. No other users. – Boutros AbiChedid Dec 20 '13 at 21:34
  • Have you tried to check the current time (not the node's timestamp)? Is the current time also different? Just to be clear - I mean the PHP time() function – rreiss Dec 21 '13 at 0:08
  • Yes when I use the PHP time() function in the code, it outputs the correct local time. Thanks for any other feedback. – Boutros AbiChedid Dec 21 '13 at 10:47
0

Problem solved:

Just in case someone else got the same problem over this. Here is what I was doing wrong (Thanks to Jay from Princeton University for pointing it out):

I set up the Date & Time for the administrator account under "/admin/people", but not the system-wide setting, which is at "/admin/config/regional/settings"

'Administration -> Regional & Language -> Date And Time' will show the date/time formats I have set up while respecting the user-chosen timezone (not the system-wide default time zone) so everything looks deceptively like it's how I want it until I log out.

So in short there is another time setting in .../admin/config/regional/settings
that I wasn't aware off.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.