0

I want to have a relationship between the the author of the node ($uid) and the view results, seems straightforward but I'm not getting it. On the view, I've added the relationship to content:author and then used a contextual filter for the nid. Since this is a block view, I've provided the default argument from the url. It seems like I've done the very same thing before, but I'm going crazy with this case. I have noticed this time that the contextual filter doesn't ask whether to use a relationship, which seems odd.

  • I'm still unclear what the problem is. You want a relationship to the author and you have added it. You also added a node id argument that defaults to pull from the url. Then what? What is not working as you expect? Also, what path is the view displaying on (in relation to the default contextual filter)? If you want to select the author relationship for the nid contextual filter you can't because it isn't relevant, the author doesn't have an nid, the node does. – rooby Dec 23 '13 at 3:55
  • The part that's not working as expected is the argument is not relevant, as you said: all of the content is showing, without any relationship. What I want is for all of the content related to the uid on the node to show up. In other words, the user who created the node, show me a list of all the other content he/she has created, too. – steve Dec 23 '13 at 4:02
  • @steve, If Content:author relationship is there, you should see a user option in 'filter' drop down box while adding a contextual filter. You can select 'uid' thereafter that will be using The 'Author' relationship. I could see that working. :) – Jeet Dec 23 '13 at 5:48
2

Hope this will help you, To display all content created by author who created the current node loaded, No need to make any relationship, Just add a Configure contextual filter: Content: Author uid check the bellow options, enter image description here

  • Oh yeah.This is better solution than my answer. However you will also want to add a node id contextual filter with default fromurl and exclude it, so that you don't get the node of the current page appearing the your listing. – rooby Dec 23 '13 at 7:45
  • This is the frustrating this about Views, I would have thought that would be the way to produce my results (and it is, thanks!); but when I was checking by adding the nid for the argument preview in Views, I wasn't seeing anything. Nevertheless, when I checked the actual node, it worked. – steve Dec 23 '13 at 12:25
1

For this you need 2 relationships.

You have a node view with the relationships:
Content: Author
User: Content authored (this one uses the previous relationship)

The contextual filter will use no relationship and your fields and filters will probably all all use the second relationship.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.