0

I am using some views fields as links to the main content. To make the links use the content URL aliases I have:

  • Added NID as a field, excluded it from display, and moved it to top of the list

  • In the "Rewrite results" section of the field I want to use as a link, I checked "Output this field as link" and for the link path, I entered node/[nid].

as explained here.

This seemed to work fine.

But when you visit the site as an authenticated user, these link fields start to display the node/[nid] style URLs.

The URL aliases are still working even for the authenticated user. The title field in a given view for instance, has the aliased path for the href and the link works. But the fields I made into a link with node/[nid] token are not aliased.

I have tried deleting and updating the aliases and clearing the caches. Although not really related, I also tried to turn on and off the "ignore admin path" option in the Global Redirect module settings. Nothing changes as the problem is not limited with the admin pages.

Any ideas why this is happening and how I can solve this?

  • when you try to aliased path what you see? – Yusef Mohamadi Dec 24 '13 at 12:43
  • @zhilevan, the aliased path is working. The title field for instance, has the aliased path for the href. But the fields I made into a link with node/[nid] token are not aliased. – turzifer Dec 24 '13 at 13:14
  • Do you Try clear cache? – Yusef Mohamadi Dec 24 '13 at 13:18
  • @zhilevan, considering your comments, I edited the question. – turzifer Dec 25 '13 at 7:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.