0

i have multiple nodes each per language and the default is English(node/1). For french node(node/2) after submitting the details of the contact form, the details not getting displayed in Webform-Confirmation.tpl.php page, however when i do the same in default English node, it is getting displayed. any configuration should i do for this please help

8
  • Have you overridden template webform-confirmation.tpl.php for node/2? Dec 27 '13 at 9:55
  • yes made it as webform-confirmation.tpl.2.php still not worked
    – user24393
    Dec 27 '13 at 9:57
  • It should be webform-confirmation-[nid].tpl.php and you have to create template for other node. Dec 27 '13 at 9:59
  • how to create that template for new node.is there any work around, as am very new to drupal am struggling with this
    – user24393
    Dec 27 '13 at 10:01
  • Copy file from webform module and rename file as webform-confirmation-[nid].tpl.php and you should replace [nid] with your node id and clear cache. Dec 27 '13 at 10:04
0

You should set Redirection location of webform in form settings.

  • Edit your webform node.
  • Click on webform tab in top of page and it will redirect you to webform configuration of the node.
  • Click on form settings link in webform
  • Checked Confirmation page radios in Redirection location field-set and save the form.

webform submission

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.