3

I have a strange problem... I just uploaded our new Drupal site. Everything looks great - until we enabled SSL. When SSL is enabled, the look-and-feel of the sight changes slightly. The fonts change in a few places and the width is off on the main pane. It's as if something in CSS is getting messed up. But I can see that the CSS files are being loaded.

I disabled caching and Page Speed, thinking perhaps that was the issue.. but disabling that didn't fix the problem.

I'm really at a loss here. Does anyone have any suggestions on how to tackle this issue?

I'm running Drupal 7.24 on an Apache web server.

Thanks!

  • It's not Drupal. Can you carefully check 1 element on your page, that looks different, with firebug? What styles are different and what are the CSS files used in both cases? – user4035 Dec 30 '13 at 3:32
  • Thank you for the response. I followed your suggestion and inspected an element... several actually... the same CSS files are used. Everything looks identical. It's really strange. – mrbranden Dec 30 '13 at 3:45
  • Do you have any external CSS or js files that gets loaded from a non ssl url? If yes, that may be the issue. If your site is running on SSL and have non SSL CSS fetches, then the browsers(at the least IE) will pop up a message asking you if the non secure contents be loaded? The files will be loaded only if you allow to connect to a non SSL server. – vishnuvp Dec 30 '13 at 10:59
  • Thanks! As I stated in my previous comment above, I was pulling in a font from fonts.googleapis.com over http. I changed that to https and the problem went away! – mrbranden Dec 30 '13 at 12:02
5

If you have enabled SSL, it may happen that some browsers may block the resources that are not using https:// in their URLs. While Chrome and Firefox manage to work fine in some cases, Internet Explorer has a strange behaviour.

I would suggest you to check if external scripts, images, or CSS styles you are using in you website use http:// in their URLs, and change them if they don't use https://.

| improve this answer | |
  • 1
    Thank you! That was precisely the problem. I was pulling in some fonts from fonts.googleapis.com. Changing that to "https" fixed the problem. Thanks again! – mrbranden Dec 30 '13 at 12:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.