I have a strange problem on all my websites when I did an upgrade from drupal 7.22 to drupal 7.24: After the update my default theme ("atlas") has been disabled. My websites have been installed with the profile "atlas" based on drupal 7.22.

Does anybody have an idea why this happens? Is it safe just to enable the theme again? Does anybody have hints how I can investigate this problem?



Drupal doesn't support having the same name for modules/themes/profiles it requires them to all be separately name-spaced see https://drupal.org/node/371375 for more background.

You should rename your theme to something different and update all the themes hooks.

  • thanks for this feedback. I was searching hours in the internet and also talked to the seller of the profile. It would be great when this is the solution. As I understand from the discussion you referenced, it is probably easier to change the profile name instead the theme name. Can you tell me how I can do this? Unfortunately I am not programmer, I could only edit files or change the DB – Beauregard Jan 2 '14 at 19:03
  • Honestly I'd change the theme name rather than the profile as if there are any updates to the profile then your back at square one. If you download a copy of your theme you'll need to change any reference to atlas (including the folder name) a simple find and replace should work, then re-upload to your site making sure that you delete the old theme folder. – digital Jan 3 '14 at 11:23

Potential source of the problem and solution

As a developer I asked pointed out, the problem could be that I upgraded drupal core but in my installed version my initial profile "atlas" was still marked as active. He recommended

a) to set in the system table status=1 for the "standard" install profile

b) in the variable table change the install_profile to "standard".

This is also described here: http://flipbit.ca/2012/05/drupal7-fix-install-profile-name/#20120518solution

I tested this and it worked. An upgrade after changing these two parameters did not disable the theme.

So, this worked for me. I am not programmer and can therefore not judge whether this is the final bug fix or only a fix by coincidence. Reading the many discussions about installation profiles and how they are designed in drupal leaves some open questions.... One user also asked whether I replaced the profile-directory during the udpate. I did this. I tested it without replacing, but the problem remained.

Unfortunately I could also nowhere find clear information about how to disable a profile. In my case I used the profile only for the first installation but will not use it in the future anymore.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.