1

My Drush was installed on /usr/local/lib/php/drush; I have now removed it from there, and installed it on /usr/share/drush.

I run the following commands.

chmod u+x /usr/share/drush/drush
ln -s /usr/share/drush/drush /usr/bin/drush

When I type which drush, it shows /usr/bin/drush, but when I run drush status or drush version, or any drush command, it doesn't show any result or error.

I was previously seeing errors related to Ioncube and Zend Guard Loader, but those have now been resolved, while Drush is still not working.

From php -v, I get the following output.

PHP 5.4.23 (cli) (built: Jan 9 2014 23:00:41) Copyright (c) 1997-2013 The PHP Group Zend Engine v2.4.0, Copyright (c) 1998-2013 Zend Technologies with the ionCube PHP Loader v4.4.1, Copyright (c) 2002-2013, by ionCube Ltd., and with Zend Guard Loader v3.3, Copyright (c) 1998-2013, by Zend Technologies

My drush version is drush-7.x-5.9.

  • Thanks for updating, I took out the error messages you've resolved in case they distract from the real issue, hope you don't mind...do you see any errors in the php cli error log? – Clive Jan 10 '14 at 18:39
  • Thanks @Clive can you please tell me where can I find that php cli error log – Fahad Jan 10 '14 at 18:55
  • Off the top of my head try /var/log/httpd/error_log. I'm not sure if cPanel changes that from the default on cent os – Clive Jan 10 '14 at 18:56
  • @Clive It depends on how you have CP installed. The installs I have seen separate out per host you have defined. – mpdonadio Jan 10 '14 at 22:09
  • cant find error_log under this location /var/log/httpd/ – Fahad Jan 10 '14 at 22:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.