1

Ok, so I have a table in my database that I am outputting by using a combination of the data module to bring in a table from my database and the views module so it can be displayed. The page with the view can be seen at http://apollo.tbc.iit.edu/~spaceweather/?q=distribute-data.

I want to enable the column fileSymlink to output as a link.

Below is an example of what the table looks like.

enter image description here

In order to try to enable the links in the last column:

  1. Go to edit view

  2. Click on the column in the fields section that corresponds to that column (i.e., fileSymlink)

  3. Open the drop down "Rewrite Results"
  4. Check to enable "Output this field as a link"

There is then a text form I need to fill out and I'm unsure what to put there. The text in the column is the link. For example if someone clicked on the text in the column DownloadData/cases/grid108/297/txt/channel_dataout_2013_297_0100.log, it would take them to apollo.tbc.iit.edu/~spaceweather/DownloadData/cases/grid108/297/txt/channel_dataout_2013_297_0100.log.

Am I doing this correctly, or should I be actually storing the HTML in the columns and having views render HTML instead?

I'm not set on one way of doing this, if there is any better way. Any suggestion is very appreciated.

2

Don't the instructions for the link field tell you that you can use tokens in the URL? I do not have a view with a text field handy, but here is a screenshot from a view where I make a custom link for the title field:

Views admin UI editing a custom link

Scroll down to the Replacement Tokens and expand that field. One of the options should be something like [field_fileSymLink]. Then you should be able to use something like http://apollo.tbc.iit.edu/~spaceweather/[field_fileSymLink] or maybe just /[field_fileSymLink].

|improve this answer|||||
  • Great thanks. I have not dealt with tokens yet. I used the "[fileSymlink]" token by putting that text into the Link Path form there. The only issue now is that it automatically puts "/?q=" before the [fileSymlink] so that the final link looks like: apollo.tbc.iit.edu/~spaceweather/?q=DownloadData/cases/grid108/…. This is not the right path. I need to remove that /?q= – Dr. Dan Jan 11 '14 at 21:48
  • I fixed it. To remove that "?q=" I did two things. I checked "External Server URL" to trick it into not using the ?q=. For some reason that removed that part of it and I also was more explicit with the "Link Path" that i used. The path i used is: "apollo.tbc.iit.edu/~spaceweather/[fileSymlink]". – Dr. Dan Jan 11 '14 at 22:36
1

For those who are wondering why the hell nothing happens, just uncheck Link this field to its taxonomy term page.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.