0

The ckeditor is switched off by default. If there is no text present in the field while editing, the cck provides a wysiwyg interface with no text present when rich text is toggled on. However if any text is present and Rich Text editor is switched on then a particular page of the site gets rendered instead of the text. On switching off rich text the rendered page html gets displayed. Please help.

CKEditor version is latest(7.x-1.13)

Entire page being rendered

  • If this happens on clean install, you need to file a bug report. If it happens on install with a lot of modules etc, we need more detail. Now it's unanswerable. – Mołot Jan 13 '14 at 11:46
  • Can you share the details that may be required. The same html gets rendered even in the admin page of CKEditor: /admin/config/content/ckeditor/edit/Full under editor appearance. I will try to isolate this issue in a dev build in the meantime. – Amit Sedai Jan 13 '14 at 11:50
  • well, have seen it after ajax/js error in the content edit form, disable your js first! – Pan Chrono Jan 13 '14 at 19:18
0

The issue was due to a php code used in the donate button of the same page which got rendered in all wysiwyg fields. There was error in the code which disallowed the search to function properly. I was able to identify the issue using elysia cron which displayed errors when search cron was running. Checking the logs helped me resolve the issue. Error in one page could cause the CKEditor to display the same page for all wysiwyg fields when switching on rich text is interesting. Thanks.

  • Please post some tips to be used in order to solve the issue I am facing the same issue but didn't find any clear solution besides we need the search module – Mohammed Gomma Aug 25 '15 at 10:07
  • Do you have any custom php code executing in the same page. The earlier problem got resolved on fixing the php code. – Amit Sedai Aug 30 '15 at 7:17
  • No custom php code BTW I realize disappearing when I did re indexing search – Mohammed Gomma Aug 30 '15 at 8:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.