Questions tagged [composer]

Use it for questions about the PHP application library dependency manager (Composer).

Filter by
Sorted by
Tagged with
0 votes
1 answer
113 views

Including modules in Git repository [duplicate]

Non core third party modules are maintained in modules directory in the Drupal root directory. Should this directory be added to the .gitignore file? If a module is upgraded in a Staging system then ...
  • 3
0 votes
0 answers
78 views

System updates, now config page errors, drush ends abnormally

After an update failed I'm seeing the following issues. I have tried several things to recover. I do have a database backup, but I am not sure on how to restore using Drush (and I'm concerned because ...
  • 121
1 vote
2 answers
235 views

How do I install my own, custom module dependant on Composer?

I've looked all over, but there seems to be no advice on this online. I've recently updated a Drupal 8 site to Drupal 9. I wasn't using composer before, and so I've used composerize-drupal to make the ...
0 votes
1 answer
377 views

Applying a patch - how? [duplicate]

Im trying to install Radix on Drupal 9 (Drush 10) - Installation keeps failing in composer / drush en radix and I have tracked it down to a current "bug" (or atleast a closed bug now) which ...
  • 173
0 votes
2 answers
846 views

How to Fix drush installation - path or alias to drupal root

I had 10.6.2 working - on Centos 7 and today it is just GONE. I had to remove phpunit and apparently it took the drush pathing setup for drush with it. Now it says it is installed but the command is ...
1 vote
0 answers
52 views

Install newer packages without conflicting with core-recommended?

Is there a way to install third party packages without conflicting with core-recommended? Example: Your requirements could not be resolved to an installable set of packages. Problem 1 - spatie/...
  • 27.2k
2 votes
1 answer
326 views

drupal-scaffold composer append robots.txt

We recently upgraded to Drupal 9.3.0 with the composer layout. Each time we execute composer update the contents of robots.txt is overlayed with the file located in core/assets/scaffold/files/robots....
  • 543
0 votes
0 answers
710 views

Composer Remove leaves files and references in composer.lock

I'm trying to update my site from D8 to D9 and there are a few modules I no longer need and am trying to get rid of. I run composer remove drupal/varbase_core and it removes it from my composer.json, ...
0 votes
0 answers
341 views

LDAP integration not working with Drupal 9 (using Ludwig as a composer alternative - was working under Drupal 8)

I 'm having a problem since updating to Drupal 9, with regards to LDAP integration. Previously, while on Drupal 8, I had successfully integrated my schools LDAP for users authentication, using the ...
  • 169
0 votes
1 answer
124 views

Tarball 9.3.0 to Composer 9.3.0

We have a large production website running 8.9.20 with a Tarball directory format. We would like to make the jump to 9.3.0 and convert the site from Tarball to Composer directory format. I performed ...
  • 543
3 votes
0 answers
29 views

How do I add a dependency on a forked project? [duplicate]

I've hit a bug that requires a patch to composer.json. There's a patch in the issue queue, but it hasn't been merged yet. How do I update my composer.json to depend on the forked version of the module?...
  • 27.5k
0 votes
1 answer
259 views

Installing the dependencies of local modules without composer merge plugin

Currently I have a composer-based Drupal project with both third-party and custom modules. Third-party modules are managed by composer without any issues. But I would like my custom modules to declare ...
  • 1,387
1 vote
1 answer
205 views

Add Composer to an existing site

I built a Drupal 8.9 site with Composer on a DEV server and copied the files (& db) over to the LIVE server. The LIVE server did not have Composer installed previously so I installed it, locally. ...
  • 82
0 votes
1 answer
101 views

Is it possible to use WSL-based Drush on a Windows 10 XAMPP and if so how?

I currently use Drupal 9 but concepts about Drupal 10 may be useful. I use Windows 10 Home with XAMPP and C:/xampp/htdocs is my web application root. I want to establish a minimal Drupal development ...
  • 11
1 vote
1 answer
99 views

Uploading local files via composer

I'm using composer to manage a Drupal 9 instance. I'm brand new to composer and have no idea what i'm doing. That being said, I've successfully set it up and have used it to install modules and an ...
  • 11
0 votes
1 answer
55 views

Upgrading to Composer 2 blocked by Symfony dependecies

I have an existing Drupal 8.9.16 site which uses Composer 1 (and Commerce 2.24). I am trying to upgrade to using Composer 2 using this guide: https://www.drupal.org/docs/develop/using-composer/...
  • 1,008
-3 votes
1 answer
673 views

Upgrading from 8.9.19 to 9 fails because of root composer.json require (^8.8.0)

My upgrade is failing. I am at 8.9.19 and I used upgrade-status to make sure all my modules are compatible with next major core version. I am following instructions at https://www.drupal.org/docs/...
  • 429
0 votes
2 answers
67 views

What's the best way to migrate from manual upgrades to composer updates?

I have an 8.9.19 installation that I would like to move over to use composer. What's the best way to migrate the installation to use composer upgrades? Manual installations are becoming a real pain.
  • 1,983
2 votes
1 answer
214 views

Is there any problem with installing composer globally?

I have a VPS and will be hosting a mixture of drupal 8 and drupal 9 sites. I need to install composer to manage the sites. Is there any need to install composer in a project folder or can I just ...
2 votes
1 answer
1k views

Trouble with the upgrade of core 8.9 to 9.2

We are in the process of migrating to Drupal 9, and I am having nothing but problems with composer and trying to get Drupal core updated. I have provided my composer.json file, and a HUGE list of ...
  • 171
1 vote
1 answer
483 views

How target specific version of fork based merge request (MR) patch

I'm upgrading the core from 9.1.7 to 9.2.5, however there's a patch I don't how to upgrade. This is the relative issue. The file 2897638-48.patch is currently used. The patch's work meanwhile proceed ...
  • 655
2 votes
2 answers
294 views

What is the proper process to customize htaccess files?

We have custom redirect links that use the RedirectMatch rules that redirect based on a root path. We'd rather handle these at the web server level rather than using the Redirect module (if it can ...
  • 471
0 votes
1 answer
101 views

drupalcommerce/project-base prohibits upgrade to Drupal 9.2.4

I'm running into composer errors while trying to update a Drupal Commerce site to Drupal 9.2.4. I'm not sure how to interpret this output when I try composer prohibits drupal/core 9.2.4 results: https:...
0 votes
1 answer
437 views

Why is composer deleting and reinstalling core?

I am running Drupal 9.2.4 on Lando on Mac Big Sur. When I use composer to install a module it first deletes core. Removing package drupal/core so that it can be re-installed and re-patched. - ...
1 vote
1 answer
209 views

Should I remove "Commerce Base" from site before an upgrade?

The "Upgrade Status" module reports that "Commerce Base" exists in site file structure, but is not installed and suggests removing it. I expect that the Commerce project references ...
2 votes
2 answers
1k views

Why Can't I Upgrade from 9.2.3 to 9.2.4 Using Composer?

If I check for outdated artifacts using: composer outdated "drupal/*" I can see Core needs updating: drupal/core 9.2.3 9.2.4 drupal/core-composer-scaffold ...
  • 69
0 votes
1 answer
210 views

Composer require installation profile constraint match error

I am trying to download this install profile https://github.com/UH-StudentServices/student_guide I added it to composer.json like this "repositories": [ { "type"...
  • 441
0 votes
1 answer
159 views

Cannot update Group module with composer

We are using the Group module on our D8 site. We use composer to manage our modules and dependencies. I am somewhat of a composer novice, so it's possible that the solution is right in front of me, ...
  • 447
1 vote
2 answers
2k views

Composer not updating modules

I have a Drupal 8.9.16 website and when I try running composer update to update the modules, I get this output $ composer update Loading composer repositories with package information Updating ...
  • 82
0 votes
0 answers
785 views

Issues after updating Composer 2

I have been using drupal for over a month now. I am unable to install modules properly because of the composer 2 updating issues. So far I have made the following changes while updating composer 2 &...
0 votes
1 answer
2k views

Locked to version problem when upgrading

Every time I run the composer command to upgrade Drupal 8.9.16 to Drupal 9, it notifies me that there is a problem with a module. For example, I run: composer require drupal/core --with-all-...
  • 3,377
0 votes
1 answer
145 views

How to update a module in production?

I am using git to deploy my composer.lock to production. Contrib is not part of my git repo. Therefore, in production I then run composer install to add contrib to production. What happens when I ...
  • 79
0 votes
0 answers
143 views

Module update with composer, updates module but not really

I am updating modules on my drupal site and I am using the composer like this: composer require 'drupal/module' The output I get from composer looks like everything is working fine but when I go to ...
  • 402
0 votes
1 answer
947 views

upgrade_status - unexpected error about PHP version

I'm doing preparatory work for upgrading a site from D8 to D9... The Drupal dev site (macOS 10.14.6 served with Laravel Vagrant) is running PHP 7.3.28, both on command line and php-fpm, and I'm seeing ...
7 votes
1 answer
922 views

How do I apply patches from a merge request? [duplicate]

I used the patch #48 of Views exposed sort identifiers are not configurable. I need to update the core, and apply the latest rebased version of that. However, the issue hasn't be marked Fixed, and I ...
  • 655
1 vote
1 answer
543 views

How do I avoid overwriting the .htaccess file when I use the Compose command?

On my new Drupal 9 website, I customized the .htaccess file and the robots.txt file I don't want its files to be overwritten when updating with Composer. I added the lines below in my composer.json ...
  • 25
0 votes
0 answers
157 views

Composer memory limit error on update ( AWS Lightsail)

I'm running an AWS lightsail server for a Drupal 8 qa site. I'm getting an out of memory error when running update. I created a new server with 2GB of memory, and was able to run updates for a few ...
  • 429
0 votes
0 answers
33 views

Update installs a beta version [duplicate]

I'm trying to update Drupal from 9.1.8 to 9.1.9. However, running a composer update jumps to 9.2-beta2. I'm not sure how to fix it so that it sticks to the recommended version. My composer.json has ...
  • 482
1 vote
0 answers
140 views

Drush can't find commands inside vagrant VM

I have a new install of Drupal 9.1.8, with drush 10.5 installed through composer inside a Vagrant VM. But drush list gives: Available commands: help Displays help for a command list Lists ...
4 votes
1 answer
2k views

What is the best practice for handling abandoned packages required by the drupal core?

When I run composer update on a Drupal 9 website, I get this warning: Package doctrine/reflection is abandoned, you should avoid using it. Use roave/better-reflection instead. A similar question has ...
1 vote
1 answer
270 views

Trait 'Drupal\entity\Form\EntityDuplicateFormTrait' not found, while setting up existing site

I'm in the process of attempting to setup a development environment for a Drupal site that's been provided by a vendor. From what I've been told, the sites been setup and running on our UAT (Ubuntu) ...
2 votes
1 answer
155 views

How is composer including a dependent module?

I have a composer managed Drupal project based on drupal/recommended-project. I'm installing a contrib module, domain_group, and I'm seeing that composer is auto-including a required dependency, even ...
  • 7,472
0 votes
0 answers
147 views

Composer require drupal/social_auth_google - Your requirements could not be resolved to an installable set of packages

Previously I got an error with the command composer require "drupal/social_auth_google:^2.0" So I tried; composer require "drupal/social_api:2.x-dev" "drupal/social_auth:2.x-...
  • 407
0 votes
1 answer
108 views

How to override version of drupal-library (JavaScript library) included with composer merge-plugin?

I'm using Webform with the composer-merge plugin to bring in its libraries: Relevant parts of my composer.json file: "extra": { "installer-paths": { "...
  • 1,352
0 votes
0 answers
66 views

Swiftmailer prevent composer updates

I have an issue with composer and Drupal 8.9.13. When I try to update Drupal, I always get the next error and I don't find a way to solve it: #$> php -d memory_limit=-1 composer.phar update drupal/...
  • 612
0 votes
1 answer
148 views

Installing a v8 module [duplicate]

If a contrib module's info.yml contains core: 8.x and not core_version_requirement: ^8.8 || ^9, how can a site be upgraded to Drupal 9 using composer? composer update downloads modules in "...
  • 285
0 votes
2 answers
626 views

Composer won't upgrade drupal/core-recommended

My composer.json is below { "name": "drupal/recommended-project&...
  • 1
3 votes
2 answers
399 views

Installing Acquia BLT on an existing site

We have a working Drupal 9 installation (running within Docksal), which has pretty much the whole install living in docroot/ except for the config/ directory, which is a sibling of docroot/. This ...
  • 31
0 votes
3 answers
2k views

Stuck in my config import because of guzzlehttp/guzzle error

I am trying to import the config from another of my Drupal 9.1.4 projects with Composer / Drush (drush config-import from a folder source, all two websites on my local repository on Xampp), but a ...
-2 votes
1 answer
756 views

Issue installing module via composer. - "package is fixed"

I've installed Drupal via Composer as well as 2 other modules and everything seemed ok. But now I tried installing Nodeaccess and get the following error message in console: Your requirements could ...
  • 17

1
2
3 4 5
12