Questions tagged [debugging]

Use it for questions about module and theme debugging (e.g. "How do I debug this situation?").

120 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
3
votes
1answer
144 views

How to attach xdebug to drush in docker

How can I "attach" xdebug to drush in a docker container? By that I mean, how can I have xdebug show me a history of an import script? And to look at the single variables that are defined and ...
3
votes
1answer
252 views

Output array data on drush error when showing stack trace

I'm trying to install a module, but its giving me errors during a drush enable. It shows the stack trace log and I can see it has something to do with the flag_lists_type during the install process. I ...
3
votes
1answer
1k views

How to embed a Rules Link in a View in order to trigger a Rules link to run?

What is the general process to embed a Rules Link in a View in order to trigger a Rules link to run? I have used the Rules Link module to create a Rules Link embedded in a View (it's a View that ...
3
votes
1answer
629 views

dpm function doesn't display results for arrays

I need to work over the hook_menu_alter function and I found that the dpm() function is not working for arrays. I have devel and admin_devel enabled. I flushed all cache to make sure the hook is fired....
3
votes
1answer
519 views

How to display devel dpm messages on a panels generated page?

I am testing a custom module for a site using Panels Everywhere & Panels. I need to put the results of a Devel module dpm() message into a pane so that I can see it on page displays. Does anyone ...
2
votes
0answers
250 views

Feeds SQL Import shows data in preview but fails to import

I have a problem on a client site with a Feeds import that shows the correct data within the import preview but does not copy the data across to the assigned field during the import. There are 18 ...
2
votes
0answers
33 views

missing format error

Hi Guys I am having a missing format: 1. alert on my web most of the time is when loging out of my web on when I access the front page, this is the log message filter Date Saturday, August 1, 2015 ...
2
votes
0answers
183 views

What is the difference between Query build time Query execute time View render time in drupal veiws

I'm using drupal views and set Live preview settings enabled. I'm curious about the difference between three factors: build time, execute time and render time. Sometime when I change a filter or sort ...
2
votes
0answers
309 views

Debugging Drupal via Drush on Eclipse

I've been trying to set up a debug environment for Drush using Eclipse(Kepler), in order to find out why the difference of the result of running hook_install() between via Web UI and via "Drush en". ...
2
votes
1answer
3k views

Validating node creation / edit form

I'm using form_alter to play with the node form for a specific content type. This content type has many different fields and I'm also using Field Collection module to organize all these fields & ...
2
votes
2answers
195 views

“This is a debugging block” on Permissions page

On my dev site, everything is working fine EXCEPT the permissions pages. This includes /admin/people/permissions and the permissions pages for individual modules (example: /admin/people/permissions#...
2
votes
1answer
212 views

Tuning with New Relic

So I've finally delved into tuning up my aging Drupal 6 site using NewRelic and like most I'm amazed at what their product has to offer. Very useful for honing in on problem areas. However, being new ...
2
votes
0answers
206 views

How to debug IMCE javascript problem

I have a D7 site with CKEditor + IMCE. The main site (www.example.com) IMCE works as expected. My staging site (cloned w/ Backup & Migrate) (staging.example.com) IMCE javascript is not working ...
1
vote
0answers
104 views

Render HTML in Drupal 8 error messages

I'm working with Twig templates, and often see messages like this in the browser when I make a mistake: The website encountered an unexpected error. Please try again later.</br></br><...
1
vote
2answers
78 views

Manipulate a render array in hook_node_view

I'm wanting to modify the contents of some fields at display time so looked at hook_node_view(), however, the $build array is not what I'm expecting, if I dump it with var_dump it is thousands of ...
1
vote
0answers
18 views

Left to right mark added to field name

Using Drupal's admin I added to an existing content type a new text field with the machine name field_note. When fetching the field in my code I want to check if $field_name == 'field_note' but it ...
1
vote
1answer
949 views

500 error without any error log entry

Migrated a Drupal 8 site to another server running apache2 PHP 5.5.9 (should be supported). Apache returns 500 when index.php requested, but no errors are logged anywhere. I tested by forcing an ...
1
vote
0answers
42 views

Page not found errors for images

The site becomes painfully slow at times and when I look into "Recent Log Mesaages" logs such as this is frequently found. The Location shows: http://example.com/sites/default/files/styles/featured/...
1
vote
0answers
34 views

Reaction rule raises TypeError

I have a working Drupal 8.3.7 installation and use the rules3.0alpha module. I add a reaction rule that is applied After saving new comment. That's all. Now, when I try to save a comment, I get an ...
1
vote
2answers
193 views

How to access all of the properties related to Commerce Line Item entity in a rule?

I wonder how I can access all of the line item properties in Rules? For example in a Rules event "Before saving a line item" I can show a debug message of the line item. It has different properties ...
1
vote
0answers
127 views

Unable to install / enable SimpleTest

When I try to install SimpleTest via Extend > Testing > Install, I get the following error: The testing framework requires the sites/simpletest directory to exist and be writable in order to run ...
1
vote
0answers
122 views

'unexpected error' when visiting any page the first time, but not the second

Quite suddenly, my site has begun behaving erratically. No matter whether the page is an admin page, or a page using my custom theme I receive the 'unexpected error' page whenever I visit the page for ...
1
vote
1answer
157 views

Why can't I run krumo() on a node page?

I called krumo() inside hook_node_load(). function mymodule1_node_load($nodes, $types) { krumo($nodes); } It works on my front page, but not on a node page. I get this error message: Fatal ...
1
vote
0answers
36 views

Drupal Site No Longer Rendering a Specific Theme - How to Troubleshoot?

I have a Drupal 8 instance running on a Ubuntu 16.04 virtual machine through Apache2 to test with and learn Drupal. Up until today, everything has worked correctly, but on starting my VM this morning ...
1
vote
0answers
397 views

How do I debug hook_mail_alter()?

I need to debug $message on hook_mail_alter(&$message). In D7 it was pretty easy to dpm() on hook_mail_alter(). Now in D8 dpm() doesn't print the nicest output anymore. I'ld like to see the ...
1
vote
0answers
290 views

How to expose field collection's items id or UUID to the front end?

I'm working with the Drupal 8 field collections and currently have setup a custom collection that is an editable widget on the edit pages. I'm trying to target these collection items via their unique ...
1
vote
0answers
611 views

Drupal 8.2.2 kint output in template not working

We are trying to use the kint() or drump() debugging functions inside twig templates in Drupal 8 but both does not seem to be working even though we have tried all the approces to get them working ...
1
vote
1answer
23 views

New Account, change Duplicate E-mail error

I run a drupal / civicrm build for a non-profit. We are very careful with our members information, and want to make sure that no one trying to, would be able to figure out if someone they knew was a ...
1
vote
0answers
45 views

Exported feature, panelizer fields are unknown when installing in another environment

I can't seem to find out why my panelizer default layout is not being installed correctly after being exported using features. I am exporting a content type, with some default panelizer settings. ...
1
vote
0answers
44 views

Site crashed: Ajax error

I have been looking for a solution on the internet before asking for your help here. My drupal site was working fine since yesterday when I create a calendar event chain ( this is a custom module) ...
1
vote
0answers
25 views

Commerce File - Error

I got the following Error when a licensed commerce file should be shown in the "Files" tab of the user account: Notice: Undefined offset: 0 in commerce_file_handler_field_download_limit->pre_render(...
1
vote
1answer
85 views

How to avoid missing status for Workflow access module permission just after node creation?

I am using Workflow 7.x-2.8 to manage peer-reviewing publication. When an authenticated user (an author) creates a post, he can choose a first workflow state transition from creation (by default) to ...
1
vote
1answer
669 views

Kint breaks in template and doesn't allow me to view anything

in my template I am trying to view the contents of Childen in a form template. <form{{ attributes }}> {{ kint(children) }} </form> However, the result I get is a useless broken kint ...
1
vote
1answer
345 views

Debugging your code under SimpleTest when the behavior is different

I'm dealing with a weird problem where a few of my tests are dying from exceptions when run inside of SimpleTest, but I'm unable to reproduce the problem outside of the SimpleTest environment. In ...
1
vote
0answers
86 views

Using entity_metadata_wrapper() and dpm() in node template causes subsequent nodes to return empty values

I've create a view which displays all nodes with content type location. This view renders the node using it's teaser display, which I've created a custom node--location--teaser.tpl.php for. In this ...
1
vote
0answers
99 views

Directory permissions and appearance issues after moving site

I recently moved my drupal site and am having issues with it the most pressing issue is one of permissions for temporary directory. there is also some weird css stuff going on but ill figure them ut ...
1
vote
0answers
221 views

Serve 404 page on view with contextual filter?

We use facet filters to create collections of content. The facet filters create url arguments that look like this www.example.com/l/language or www.example.com/l/language/g/gender For SEO reasons we ...
1
vote
0answers
786 views

The website encountered an unexpected error. try again later

Hi guys I get this message when trying to get acces to my web loging as admin this is the error The website encountered an unexpected error. Please try again later. is only when trying to get access ...
1
vote
0answers
45 views

CiviCRM on Drupal: Array to string conversion error in BAO setting.php in Display preferences

I'm receiving this error after a fresh install of civicrm-4.4.17 on drupal-7.38. While attempting to go through the configuration checklist I also noticed that the items were not turning green after ...
1
vote
0answers
218 views

error “EntityMalformedException” when creating a node as guest

We have a node type with permission to create new nodes for guests. When we try to create a new node of this type as guest we get the following error: EntityMalformedException: Missing bundle ...
1
vote
1answer
141 views

Invalid URL Aliases in Drupal Nested Sites/Subsites - Main 404

I'm sure my title made no sense! But I'm really struggling with something and could use some assistance. I inherited a Drupal-based website a few months ago, and it was my first exposure to Drupal. ...
1
vote
1answer
55 views

Search API module causes server error when saving index fields

I am very new to Drupal, so please let me know if I'm doing something wrong. Using the Search API module, I would like to go change some fields of my Node Index. For example, I would like to uncheck ...
1
vote
2answers
96 views

Try to add in different views to a single page, keep getting “Error” message?

I have a panel where I'm pulling in 7 different views pages in different regions, and when I try and save it, I keep getting the same message-- "The website encountered an unexpected error. Please try ...
1
vote
1answer
78 views

Is there a way to trace PHP errors logged from Rules?

Occasionally I'm seeing an error in the error_log [10-Apr-2015 10:16:45 America] PHP Parse error: syntax error, unexpected 'Some text' (T_STRING) in /home/simulab1/public_html/profiles/...
1
vote
0answers
228 views

View XML Request when using WSClient and Rules

I am building a website that uses 3rd party data from a web service. I decided to use WSClient...so far so good. I am using Rules together with WSClient to create the proper SOAP request, however I ...
1
vote
0answers
26 views

Issue with “edit” links on Menu pages

I have an unusual bug i've encountered during development of a client site -- it appears that for all Editable menus, when I click on edit, the site loops me into a Redirect Loop, pointing to a menu ...
1
vote
0answers
51 views

How to force Devel Generate to use default image when creating nodes?

I'm using Devel Generate to generate nodes which has an image field. The generation is working fine but devel uses a standar image (sort of color squares) for the created nodes instead of the default ...
1
vote
2answers
301 views

Why does dpm() sometimes fail and krumo() works

They both dump variables in the same format & style. From some articles or documentation that I'd read, it seems krumo() calls dpm(). The problem is that sometimes I call dpm($var) and nothing ...
1
vote
1answer
117 views

Views not found on disabling Page Title module

I've Views 7.x-3.7 and Page Title 7.x-2.7 installed. Since many months I'm using Meta tags and Page Title module but now I want to remove Page Title module as I don't need it since Metatag module ...
1
vote
2answers
230 views

WSOD for logged users after upgrading some module

I have updated the following modules on my website: ctools context devel ds libraries metatag pathologic rel_to_abs variable webform After the upgrade whenever I log in, I am not able to access ...