Questions tagged [drush]

Use it for questions about the command line shell and Unix scripting interface for Drupal (a.k.a. Drush).

368 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
1
vote
1answer
177 views

The database is not bootstrapped in another docker container

The following problem occurs when running certain Drush commands, such as drush en features which outputs: Command pm-enable needs a higher bootstrap level to run - you will need to invoke drush ...
1
vote
2answers
656 views

Update website from 8.0.0 to 8.6.1

I'm pretty new to Drupal and I'm trying to update a website from 8.0.0 to 8.6.1. I've followed the guide here: https://www.drupal.org/docs/8/update/update-core-via-composer The composer part went ...
1
vote
1answer
23 views

Can Drush be assigned as a ssh users default shell?

Problem: I need to allow ssh access to my web server to dev team in order to use Drush. I am reluctant to give them full SSH access due to lack of trust in their SSH skills and knowledge. Attempted ...
1
vote
0answers
447 views

Drush not installed via Composer

When I run composer require drush/drush It gives below error Using version ^9.3 for drush/drush ./composer.json has been updated Loading composer repositories with package information Updating ...
1
vote
0answers
250 views

sql:sync errors out in Drush 9

When I try the command drush sql:sync @dev.dev @self or drush sql:sync @dev.dev @local it errors with: Undefined class constant 'MYSQL_ATTR_SSL_CA' in Drush\Sql\SqlMysql->creds()...
1
vote
0answers
584 views

Drush version doesn't update and cannot get local Drupal 8 site install to work on Linux

I am having trouble completing a local install of Drupal 8 on my Linux laptop. I am following this Guide/Blog I am running Xubuntu Linux 16.04.3 LTS Composer is installed: $ which composer /usr/...
1
vote
1answer
231 views

Update Drush in Docker4drupal

I have to upgrade Drupal core to 8.4 with Composer. Drush version is 8.1.12. I use Docker4drupal for my local development environment. How do I update Drush to 9 within my docker container setup, so ...
1
vote
1answer
104 views

“Codebase is assembled with Composer instead of Drush” (but it wasn't!) message

I'm using D7 and I'm seeing the following error message any time I try to use Drush to install a module: This codebase is assembled with Composer instead of Drush. Use composer update and composer ...
1
vote
3answers
77 views

Remotes: Can a local Drush 8 be used to send commands to a remote Drupal 8.4 site which includes Drush 9?

Let's say we have a dev-ops administrator who isn't a developer and doesn't want or (normally) need a local copy of the website. As of Drupal 8.4, Drush 9 is required, and Drush 9 doesn't have a way ...
1
vote
0answers
54 views

Drush sql-dump with stored procedures

According to the current documentation I don't think this is possible, or is it? (drush sql-dump --routines doesn't work or anything like that) Aaaannndd... let's say it's not possible, and I want ...
1
vote
1answer
771 views

Config import constantly showing configs to import

Recently after doing a config import via drush (drush cim sync), the config files don't seem to import properly, as the files are listed after a supposed successful import. (and doing a cex sync shows ...
1
vote
0answers
16 views

What does the code status “build: error” signify for Drush 8?

On the install page for Drush 8, under the section "Drupal Compatibility", the code status is listed as "build: error". What are the consequences of this, if any?
1
vote
1answer
352 views

error on CLI when using drush config-import staging

I'm getting this error below whenever I try executing the commands drush config-import staging on the CLI. I'm basically in the process of migrating a drupal 7 DB to Drupal 8 and currently following ...
1
vote
0answers
923 views

Drush 9 on Windows 10 — some Drush scripts not found — but other Drush commands work

My environment: UniServerZ XIII (a form of WAMP server), Drupal 8.4.3, Drush 9.x, Windows 10 Pro. Used Composer to install Drupal and also for Drush (as a site install). Windows PATH (for local user) ...
1
vote
0answers
121 views

Why do I get this error?

I installed Drush with Composer and I get well the Drush version. drush cache-clear drush works too, but drush webform-libraries-make returns me the following error. The drush command 'webform-...
1
vote
1answer
421 views

cannot use some drush commands

I am running into some trouble with drush I can't pm-enable the modules I just downloaded with it. I did some research but none of the solution worked for me, most cases involved switching "localhost" ...
1
vote
1answer
1k views

How to get Drush in my path in Windows 10?

I have Drush 9 installed on Windows 10. I installed it via Composer using Lando. I want to put this drush in my system path so that I can use it from cmd.exe, Powershell, and so on. I want to do ...
1
vote
0answers
47 views

There is a standard for the error codes in the drush_set_error() function?

I usually use the drush_set_error() function when I want to log a error in drush, sometimes I just do something like this: drush_set_error('DRUSH_INVALID_ARGUMENT', '....'); sometimes ...
1
vote
0answers
266 views

Drupal 8 User feature export display errors

I am getting errors once export user feature. I have just export and put inside my module folder. Drush show below error: Symfony\Component\DependencyInjection\Exception\ParameterNotFoundException: ...
1
vote
0answers
79 views

PHP Fatal error while updating the UUID

I am getting the following error while updating the UUID with sudo drush config-set "system.site" uuid "d523bcdf-9d4b-45f4-9acc-a97ba4889b66" on Drupal 8.2.x. PHP Fatal error: Class Symfony\...
1
vote
0answers
325 views

Fatal error: Cannot redeclare composerRequireDrupal8()

I am using Composer and Drush. Everything was working smoothly, but after I installed the Panels module with Composer, I started getting the following error all the times I run Drush. Fatal error: ...
1
vote
0answers
95 views

Drush pm-list needs a higher bootstrap level to run

I am getting this error when trying to run pm-list. I am in the Drupal folder, not at the root, on Mamp Pro on my Mac using OS X El Capitan. I have tried setting the host from localhost to 127.0.0.1, ...
1
vote
0answers
725 views

How can drush site-alias show all sites, but drush @sites command don't find them?

We are running a drupal 7 multi-site installation within a (windows based) cloud service. We have drush 8.1.10 installed via composer. For the update process, I want to be able to use drush @sites ...
1
vote
0answers
365 views

Drush does not run remotely, SSH does not see Drush

I had Drush 4. Then I deleted Drush folder and installed Drush 8 through Composer for my user. Now drush command works on a server for my user. Then I try to invoke drush from my local computer it ...
1
vote
0answers
65 views

Upgrade from Drush 5->Drush 8, @sites stopped working. Bug or configuration issue?

All of this worked fine in drush 5.10. It is only since we jumped from the 5 branch directly to drush 8.1.10 that we have had the issue. The ultimate questions are: Is this a bug in drush 8 or a ...
1
vote
1answer
211 views

Unable to install lullabot/amp and sensiolabs/security-checker

i have installed amp and composer manager today i have been trying to get lullabot/amp installed, i have managed to install composer and drush on my computer but im not sure if they have been ...
1
vote
1answer
123 views

Drush is not recognizing Acquia extension

I am using Acquia and Drush 8.1.8. I am following Acquia's instructions to load Drush extensions and aliases. My ~/.drush directory looks like this: nickheiner@Nicks-MacBook-Pro.local:~/.drush λ ls -...
1
vote
0answers
236 views

`drush pm-update drupal` fails to copy to backup

Tried to update some of my Drupal 7 installation with drush. Some of them were successful while some were not. The error ones generate message like this: [foobar@server htdocs]$ drush pm-update ...
1
vote
0answers
436 views

Error 1146 Table doesn't exist checking “drush migrate-status” upgrading

I have found the next error when I tried "drush migrate-status" migrating from Drupal 7 to Drupal 8. Drupal 7.53 and Drupal 8.2.5 both with 10.0.28-MariaDB SLE 12 SP1 package. SQLSTATE[42S02]: Base ...
1
vote
1answer
419 views

Updating modules fails with XAMPP on Windows 10

I'm pretty sure I installed Drush 8 correctly on Windows 10. I ran the command window as administrator. I changed to my Drupal directory, but I get "Command pm-update needs a higher bootstrap level to ...
1
vote
0answers
226 views

remote Drush stops because of “ headers already sent”

I am struggling with a remote drush error since days, and don't find the cause. I already checked the Internet up and down for an answer, but could not find a solution for my problem (here,here and ...
1
vote
1answer
470 views

Installing a New Site with Drush and Ansible

I'm trying to create an Ansible Role to run on a VM that creates a new site (so my colleagues don't have to memorize the drush si --db-url command and automate the entire process. I'm running into a ...
1
vote
0answers
149 views

Drupal 6.37 to 8.2.x upgrade with drush fails with 1115 Unknown character set: 'utf8mb4'

I am upgrading a legacy Drupal 6.37 site running on mysql 5.1 to a fresh install of Drupal 8.2.1 with mysql 5.7.16 on a remote host. I have installed the migration modules required for drush and am ...
1
vote
0answers
93 views

“drush up” is changing my selinux context

Disclaimer: I have found a way to fix this problem short-term, but I'm curious if anyone can explain to me why it's happening, or if someone has found a better fix than what I'm doing. If it exists ...
1
vote
0answers
82 views

How to boostrap Drush from within an update hook?

I have a drush command I am using to convert field_collection to multifield. /** * Convert Field Collection to Multifield. */ function mvpd_update_7018() { module_load_include('inc', 'multifield'...
1
vote
0answers
463 views

Can you use drush to update to a different module version?

I know you can download a specific version. Example: drush dl webform-7.x-3.24 According to "drush up" the webform module is up to date. Thats fine but now I want to update the webform module to use ...
1
vote
0answers
170 views

Why does the “drush status” command result in “Permission denied”?

I installed Drush via global Composer, and it seems that it should have installed correctly. However, when I executed drush status in terminal, it resulted in Permission denied. Why is this happening ...
1
vote
2answers
302 views

Drush Update Command Won't Work for Multisites

I have a Drupal 7 site with a half-dozen multisites/subsites and I am trying to setup Drush so that I can run my modules updates from the command line for the subsites. Running Drush for the main site ...
1
vote
0answers
278 views

Commands don't work anymore on a site running on a virtual machine

To explain in specifics, when I run any drush command like drush en, drush fl or drush fra or any similar site specific commands, they don't get executed and I get the following output: The drush ...
1
vote
1answer
163 views

Why are `drush pm-list` & `drush pm-updatestatus` disabling the default theme?

I have a Drupal 7 site with 3 themes enabled: Foo Adminimal Shiny Foo is a custom theme for the front-end, located in /sites/foo/themes/ and set as the default. Adminimal and Shiny are both ...
1
vote
0answers
58 views

Does running `drush rf` detect needed updates by look at the version of files on disk or by an entry in the database?

Does running drush rf detected needed updates by looking at the version of files on disk or by an entry in the database? We run in a load balancer, fail over situations on a some production server. ...
1
vote
3answers
72 views

Numerous dependencies don't get installed with “drush en -y” command for rooms module

I tried to install the rooms module, obviously a very complex module with lots of dependencies, I tried with drush: drush en rooms -y This is the module: https://www.drupal.org/project/rooms But ...
1
vote
0answers
104 views

Create a .make file task in Bamboo by using Drush for a Drupal project

I'm setting up a CI system by using Bamboo. My aim: As soon as a change is pushed to the bitbucket server, the next task will create a ".make" file using Drush. Bamboo is also found on the same ...
1
vote
0answers
89 views

Libraries not found when installing from custom profile

I've created a custom Drupal installation profile which has the epsacrop project included in the makefile and as a requirement in the .info file. Also, the epsascrop project requires two libraries: ...
1
vote
0answers
1k views

Drush 8 / Drupal 8 fatal error class not found exception AccountInterface

I have a Windows 10 PC, using git-bash as terminal window to run drush. Drush is installed in c:\users\myname\appdata\roaming\composer\vendor\drush\drush. My apache server (using xampp) is on the d ...
1
vote
0answers
129 views

Drush hangs only when executing a command on a remote machine

I am trying to use Drush to synchronise a local dev version of my Drupal site and I've set up the following alias file (spc.aliases.drushrc.php) in my .drush directory to allow Drush to connect ...
1
vote
1answer
59 views

Can I deploy my Content on drupal using scripts?

If suppose I have a drupal application in Github and I have automated drupal installation using chef. Now I want to deploy that application content such that i can see it on my content page. I am ...
1
vote
1answer
121 views

How to drush rsync and sql-sync on windows with Acquia-Dev?

Answer (just to share some hours of experience): To get rsync and sql-sync to work on remote server using Windows (w/Aquia) it is necessary to make changes to 2 files filesystem.inc and SqlBase.php ...
1
vote
1answer
25 views

css errors main menu

I have this error with my css, what drush commands I can use to fix this? is it a permissions fix? please guide me step by step
1
vote
0answers
471 views

Drush isn't able to download updates

My sys admin hasn't made any changes to dir permissions, but lately whenever I run DRUSH UP I get the following error: [error] Unable to download drupal-7.43.tar.gz to /srv/www/htdocs from ...