Questions tagged [drush]

Use it for questions about the command line shell and Unix scripting interface for Drupal (a.k.a. Drush).

Filter by
Sorted by
Tagged with
0
votes
1answer
964 views

How to fix drush issue “Could not bootstrap at phase 5”?

I installed drush via Composer. I am using drush 9.5.2 with Drupal 8.6.4. I mention that everything is fine on local. However, in a docker instance in GitLab CI, when I execute vendor/bin/drush ...
0
votes
0answers
21 views

How to get Drush to be able to query the DB?

I am getting the following error trying to run Drush on Win10, WSL2, and DDev. I can run other Drush commands, but not all of them. How do I fix it? Command self-update was not found. Drush was unable ...
0
votes
1answer
491 views

Drush make unable to determine mime type for js

On every .js library that needs to be downloaded, I keep getting errors like: https://ajax.googleapis.com/ajax/libs/jqueryui/1.8.18/jquery-ui.min.js. Unable to determine mime type for jquery-ui.min....
1
vote
1answer
715 views

Is it possible to use drush to save a theme setting?

I need to set a theme setting via a scripting mechanism (specifically phing). Is it possible to use drush to set a very specific theme setting, without passing JSON? drush vset {theme_setting} {...
2
votes
1answer
89 views

Is it possible to set a single member of a complex-variable inside the variable table

I want to use Drush vset to modify a subset of values stored in the 'variable' table's theme_themeName_settings record. I've found references to vget and vset but all I've found so far is for the ...
2
votes
1answer
370 views

Why is the --uri option needed to return absolute URLs?

I want to execute a View and export the JSON file to the files directory. I am using Views Data Export and VDE drush add-on modules. My view has a file/PDF field and I want to provide a direct link to ...
0
votes
0answers
64 views

Issues with Drush 10.3.5 version in Ubuntu 20.04

I installed Drush 10.3.5 version via composer in Drupal 9.0.7 but I am getting a website error as follows after I ran command drush cache-rebuild. I can not access the admin page as well. The website ...
1
vote
1answer
816 views

Why do I get “Command pm-disable needs a higher bootstrap level to run”?

Running drush dis varnish in the Drupal directory gives give me this message. Command pm-disable needs a higher bootstrap level to run. Running drush --debug dis varnish -y gives the following ...
1
vote
1answer
1k views

Config import constantly showing configs to import

Recently after doing a config import via drush (drush cim sync), the config files don't seem to import properly, as the files are listed after a supposed successful import. (and doing a cex sync shows ...
3
votes
2answers
104 views

How can I export only one paragraph type, the fields, the form settings and the display settings?

Some days ago I've exported and imported a full configuration with drush cex and drush cim. What are the steps to export 1 paragraph type including the fields, form settings, display settings etc ... ...
0
votes
3answers
588 views

Why doesn't my watchdog() function run when I execute my custom module from Drush

I have a custom module that performs an import from an xml file. It can be invoked two different ways. From a menu callback or a custom drush command. The import works fine and all of it's many ...
0
votes
0answers
18 views

Drush not picking up rsync parameters from site alias

In self.yml I've got two site aliases defined like this: dev: root: /var/www/example-dev/web uri: https://dev.example.co.uk paths: public: 'sites/default/files' private: '../private' ...
0
votes
1answer
541 views

How can I prevent some configuration settings getting overwritten?

I tell drush this: drush @live cim --skip-modules=system,swiftmailer and Drush replies with this: Collection Config Operation swiftmailer.transport ...
0
votes
1answer
29 views

How do I generate-content of a particular type with drush 9.x+

root@0a581055a6ad:/opt/drupal# drush genc 10 --types=article The "--types" option does not exist. devel-generate:content [--kill] [--bundles [BUNDLES]] [--authors [AUTHORS]] [--feedback [...
2
votes
1answer
546 views

drush perm-grant gives “The drush command 'perm-grant' could not be found”

I am using drush -u 15 perm-grant --roles="site administrator" but the command returns: The drush command 'perm-grant' could not be found. any ideas about that? according this documentation the ...
0
votes
0answers
25 views

drush_backend_invoke_concurrent() alternatives

Release notes for Drush 10 claim that most of the Drush 9 commands will still run on Drush 10. So I wonder what is the alternative for drush_backend_invoke_concurrent() from backend.inc?
0
votes
0answers
34 views

Drush can't bootstrap sites

I have an Ubuntu 18.04 server where I have one Drupal 8 and two Drupal 7 sites. I have installed drush 8.4.5 which works great for the Drupal 8 site but on the 7 ones it can't bootstrap. After some ...
2
votes
1answer
31 views

Drush download, what port does it use?

I work on a Drupal 7 intranet site for a large company. The firewall on the server it is housed on currently does not allow any access to the Internet. I've been upgrading Drupal core and modules by ...
0
votes
2answers
342 views

Drush cc gives only two options even when I am in root folder

I am working with drupal 8, MAMP version 3.5, and drush version 8.1.3. I have installed drush globally and when I enter drush st it gives me complete information and shows that drush is installed but ...
1
vote
2answers
340 views

Upgraded Drupal 7.37 to 7.38 using Drush and its not working. update needs a higher bootstrap level to run - Error

I am new to Drupal. I am reading a book called Definitive Guide to Drupal 7. I had installed Drush on Windows 7 with Git as well. It was working last week. Since 7.38 is released I tried to ...
2
votes
2answers
2k views

Install Drush on shared hosting with SSH access?

I have SSH access on shared hosting and I followed this guide to install the composer: https://getcomposer.org/download/ php -r "copy('https://getcomposer.org/installer', 'composer-setup.php');" php -...
-3
votes
1answer
162 views

It's 2020, What is the best way to install Drupal 8 on a brand new install of Ubuntu 20.04 server? [closed]

It's been awhile since I worked on a Drupal 8 site. I have a freshly installed Ubuntu 20.04 server. Is there a simple one liner or script to install Drupal 8 now? Is drush still used or do people use ...
3
votes
2answers
3k views

How can I execute Drush commands programmatically?

I'm working on a Drupal 8 site, and part of the requirement is giving the client a page where they can click a button to do a particular task. I am able to do this using a Drush command from the ...
-4
votes
1answer
38 views

Why is drush dl <module_name> removed and how to use composer properly to download modules via the command line now? [closed]

Sorry but I'm a bit out dated on the new composer methods of installing modules. I was used to installing modules via dursh dl webform, but now it seems that we require to use composer require drupal/...
0
votes
2answers
2k views

Drush MAMP not working

I'm running with a big problem for hours now and it's driving me crazy, maybe one of you already know the answer. Drush seems to not want to work on my OSX (10.8.5) with MAMP (3.0.5). When I execute $...
1
vote
1answer
343 views

Drush not selecting database

I'm using a Vagrant environment generated from https://puphpet.com/ for a Drupal project & it is all going well except for Drush which gives me an error any time I try running "drush cc -all", see ...
0
votes
0answers
25 views

Drush Launcher looking for Drush in public_html when using updb

I have a drupal 8 website up and running on a server. On this server I use the Drush Launcher to work with Drush on my site. For some reason the Drush command drush updb doesn't work I get the ...
1
vote
1answer
176 views

“Codebase is assembled with Composer instead of Drush” (but it wasn't!) message

I'm using D7 and I'm seeing the following error message any time I try to use Drush to install a module: This codebase is assembled with Composer instead of Drush. Use composer update and composer ...
0
votes
4answers
861 views

drush up fails with Unknown archive format

Today, I am getting an error message when I run the Drush download or update command. drush up -y captcha fails with Unable to extract /.tmp/drush_tmp_1582749966_5e56d90e14736/captcha-7.x-1.7....
2
votes
1answer
663 views

How to use another php version for drush 9?

On live server I use differents drush and php versions for drupal 8.4 and 7. I install drush 9 to ~/drush9 directory with composer require drush/drush:9.* command. On dev server and drupal 8.4 I use ...
5
votes
3answers
3k views

Unable to load class \Drush\VersionControl\Backup

I keep getting this error : Unable to load class \Drush\VersionControl\Backup every time i attempt to update my Drupal install from 8.4.0 to 8.4.2. I am running the composer provided drush Drush ...
0
votes
1answer
30 views

How do I update an old project?

I have been tasked with updating my code shop's long-abandoned Drupal 7 codebase to the most recent Drupal core, in order to bring in the latest security fixes (it's currently using v7.67). But all ...
3
votes
2answers
462 views

Drush cim: error “Table xyz already exists”

I'm trying to deploy a dev website to a dev server. When running drush cim on the dev server, drush ends with an error message: Table honeypot_user already exists When running drush cim again ...
0
votes
1answer
27 views

It doesn't work without public_html symlink

I have just updated to Ubuntu 20.04 so have a fresh install of everything. I have a working Drupal 7 site I'll call mysite. I have Drush-launcher installed globally at /usr/local/bin/drush The file ...
2
votes
2answers
910 views

Loading a queue?

How can I use Drush to pass data into a Drupal Queue? function hook_cron_queue_info() { $queues['my_queue_name'] = array( 'worker callback' => '_my_queue_callback', // This is the callback ...
1
vote
1answer
30 views

How do I set a Boolean config variable to false?

I can't set a boolean config value to FALSE with drush. I'm using Drush 8.9.4. pk@DC:~/$ lando drush config-set advagg.settings enabled 0 -y // Do you want to update enabled key in advagg.settings ...
0
votes
1answer
392 views

Getting Drush to play with MAMP and Acquia

I have a Mac workstation which is shared between two users, User°1 who first installed the machine, and User°2 who came along after, both administrators. User°2 has installed Drush using brew and ...
4
votes
3answers
12k views

How to install drush 8 properly?

I'm trying to install drush 8 via composer: composer global require drush/drush:dev-master (source) but it gives me drush version 7.0.0 which is without D8 integration... I'm using Linux Mint 17.
3
votes
1answer
1k views

Why does cloning a private git repository via Drush make file fail using SSH authentication?

I have multiple private git accounts set up with SSH system's keychain authentication for each git repo. It works to clone private git repos from command line: git clone git@git_ssh_alias:git-...
7
votes
2answers
3k views

Add a block to a region

How can I add a block to a region using Drush? I'm using Drupal 7.0 and Drush 4.3.
1
vote
1answer
14 views

Replacement for _drush_file_private_path()

I'm trying to get File Permissions working in Drupal 8.9 with Drush 9. The old code calls _drush_file_private_path(), which doesn't exist anymore, and _drush_file_public_path() is probably a no-go as ...
1
vote
0answers
28 views

Database dump without revisions?

Are there methods to exclude revision data in a database dump? The purpose would be to reduce the file size for developers that want a db dump for local development. I know that drush sql-dump has an ...
1
vote
1answer
583 views

Updating modules fails with XAMPP on Windows 10

I'm pretty sure I installed Drush 8 correctly on Windows 10. I ran the command window as administrator. I changed to my Drupal directory, but I get "Command pm-update needs a higher bootstrap level to ...
0
votes
2answers
535 views

Cannot install Drupal via drush in the root of site

I am going absolutely insane. I have been up for several hours scouring the internet, installing, removing, installing, removing, and I CANNOT get Drupal (7 or 8) to install at the root of a site (...
1
vote
0answers
59 views

PHP Fatal error: Class 'Drush\Commands\DrushCommands' not found

I am trying to migrate data using csv source to Drupal 8 installation using Drush and Drupal Migrate Tools. I am able to execute all the drush commands including the one to check the migration status (...
1
vote
2answers
375 views

Update command won't work for multisites

I have a Drupal 7 site with a half-dozen multisites/subsites and I am trying to setup Drush so that I can run my modules updates from the command line for the subsites. Running Drush for the main site ...
2
votes
2answers
3k views

How to update core and all modules and themes from CLI?

On a LAMP environment I have a Drupal 8.5.6 website which is nearly all-core with the Bartik theme and a few stable contrib modules. Nothing is customized and I have daily backups so I don't "fear" of ...
0
votes
1answer
23 views

drush arr (drush archive-restore) says: Missing required argument: file

I have been requested, against my better advice, to try to ensure that a Drupal site for an associated part of our organisation is up to date, although the site developers left no admin maintenance ...
8
votes
4answers
5k views

How can I list only modules which need an update?

Drush 8.1.9 & Drupal 7.53. What I'm looking for is a command like drush ups but without all the modules that are [OK] – so when used with an alias of several sites I don't have to scroll through ...
1
vote
1answer
391 views

The database is not bootstrapped in another docker container

The following problem occurs when running certain Drush commands, such as drush en features which outputs: Command pm-enable needs a higher bootstrap level to run - you will need to invoke drush ...

1
2 3 4 5
38