Questions tagged [drush]

Use it for questions about the command line shell and Unix scripting interface for Drupal (a.k.a. Drush).

404 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
2
votes
0answers
115 views

What are the advantages, for managing a single multisite instance of Drupal, to using drush make instead of git fetch & merge?

I don't intend to publicly distribute an installation profile for my multisite instance. Are there still advantages to using platform/site makefiles to move code updates through dev/test/production ...
2
votes
1answer
274 views

Aegir Drush Drupal 6

I am using the Hosting module through Aegir. I created a module with some extra fields such as "site_name," "fields," and "description," which was done successfully. I want to use these fields on a ...
2
votes
3answers
2k views

Unable to connect to local MySQL db using drush sql-sync

I'm attempting to use drush sql-sync to sync my prod database to my local dev copy, and everything seems to work until drush attempts to log into the local MySQL. When it does, it throws this error: "...
2
votes
1answer
206 views

Way to prevent drush from eating custom profiles when updating core?

I use drush make with a stub .make file to download a custom profile via git. that profile has all of the modules I want all of my sites to start out with. If I then go into that site, and run "...
1
vote
0answers
26 views

Configuration export via drush randomly change the value of labels\other content in multilanguage sites

I've a multilanguage site, with Italian set as default and English as secondary language. When exporting the configuration via drush - drush cex command - sometimes the labels of other kind of content ...
1
vote
0answers
17 views

Drush 10, Drupal 9, views-bulk-operations:execute using entity:delete_action:node seems to work but won't save its changes

I'm trying a command: drush -vvv views-bulk-operations:execute -d deleteme_content entity:delete_action:node where deleteme_content is a View with translations of entities that I want to delete. The ...
1
vote
0answers
305 views

“Drupal root not found. Pass --root or a @siteAlias in order to see Drupal-specific commands”

I have multiple sites inside the same htdocs directory. In one, I removed all the folders except vendor under Web. Now drush will not work (it worked before I moved the folders). But now, it cannot ...
1
vote
0answers
34 views

Database dump without revisions?

Are there methods to exclude revision data in a database dump? The purpose would be to reduce the file size for developers that want a db dump for local development. I know that drush sql-dump has an ...
1
vote
0answers
185 views

PHP Fatal error: Class 'Drush\Commands\DrushCommands' not found

I am trying to migrate data using csv source to Drupal 8 installation using Drush and Drupal Migrate Tools. I am able to execute all the drush commands including the one to check the migration status (...
1
vote
0answers
32 views

Unable to set author and created time when translating node programmatically

I am adding translation to a node programmatically using a script which I run with drush scr. Everything works as far as adding translation and copying all the fields over. However, I am not able to ...
1
vote
0answers
452 views

'[warning] Drush command terminated abnormally.'

Drush won't run at the command line in any Drupal 8 subdomain installation: [warning] Drush command terminated abnormally. I am using GreenGeeks hosting for several Drupal 8.8.7 sites, one 8.8.6 site, ...
1
vote
0answers
566 views

Drush database issue

I have encountered an issue with Drush. I am missing a number of commands. When running a command with --debug I am told [Symfony\Component\Console\Exception\CommandNotFoundException] Command rq was ...
1
vote
0answers
51 views

Drupal Commerce 2 updating with composer

I am a retired civil servant -- NOT a developer by a long shot -- and while I have used Drupal for about 19 years, I am new to composer and drush and Drupal Commerce 2. I was able to successfully ...
1
vote
0answers
49 views

Migration executes from drush but not from UI

I have a list of migrations (custom ones but following the guidelines). The migrations have no problems being executed from console with drush mim but if I try to execute them from the migrations UI I ...
1
vote
0answers
106 views

Start migration via rest or from a button within a view

I have a bunch of migrations that update a bunch of nodes. I want to automate the process and also be able to rollback / add / update specific nodes for specific migrations. Basically I need a ...
1
vote
0answers
17 views

Drush migration argument for xml source

I asked this question a while back and it was answered correctly and helpfully. However, I'm currently looking for a different solution. I need a way to create a custom argument which I can use to ...
1
vote
0answers
139 views

Cannot update Acquia Dev Desktop Drupal Core 7.61 to 7.65 through Drush

I did a brand new install of Drupal 7.61 using Acquia Dev Desktop 2. I selected a "Standard" installation profile after launching the site in a browser. I tried to update Drupal Core through the Drush ...
1
vote
0answers
161 views

Body, files, and paths problems

I was suggested so many times to migrate my old project from D6, so I finally decided to jump into this. And as it always happens with Drupal, things never work as expected at first attempt. The old ...
1
vote
1answer
166 views

Post update hook fails to run via Drush, but works via update.php

I've implemented hook_post_update_NAME to bulk import some files into Drupal (creating file and media entities for them). This hook runs correctly when I use update.php. But it seems to silently fail ...
1
vote
2answers
41 views

Drush not “seeing” Drupal installation

I have a drupal installation running in a vagrant virtual machine. This works fine, but when I try to use Drush on this site I get very peculiar behavior. The modules that are listed when I run "...
1
vote
1answer
975 views

Why do I get “Command pm-disable needs a higher bootstrap level to run”?

Running drush dis varnish in the Drupal directory gives give me this message. Command pm-disable needs a higher bootstrap level to run. Running drush --debug dis varnish -y gives the following ...
1
vote
2answers
735 views

The missing modules don't get installed after updating with Composer

To update a site locally, I cloned the code base with git to my local computer and imported the database, then ran "composer update --with-dependencies", there were no errors, then I went to /web ...
1
vote
1answer
450 views

The database is not bootstrapped in another docker container

The following problem occurs when running certain Drush commands, such as drush en features which outputs: Command pm-enable needs a higher bootstrap level to run - you will need to invoke drush ...
1
vote
2answers
755 views

Update website from 8.0.0 to 8.6.1

I'm pretty new to Drupal and I'm trying to update a website from 8.0.0 to 8.6.1. I've followed the guide here: https://www.drupal.org/docs/8/update/update-core-via-composer The composer part went ...
1
vote
1answer
28 views

Can Drush be assigned as a ssh users default shell?

Problem: I need to allow ssh access to my web server to dev team in order to use Drush. I am reluctant to give them full SSH access due to lack of trust in their SSH skills and knowledge. Attempted ...
1
vote
0answers
876 views

Drush not installed via Composer

When I run composer require drush/drush It gives below error Using version ^9.3 for drush/drush ./composer.json has been updated Loading composer repositories with package information Updating ...
1
vote
0answers
417 views

sql:sync errors out in Drush 9

When I try the command drush sql:sync @dev.dev @self or drush sql:sync @dev.dev @local it errors with: Undefined class constant 'MYSQL_ATTR_SSL_CA' in Drush\Sql\SqlMysql->creds()...
1
vote
0answers
837 views

Drush version doesn't update and cannot get local Drupal 8 site install to work on Linux

I am having trouble completing a local install of Drupal 8 on my Linux laptop. I am following this Guide/Blog I am running Xubuntu Linux 16.04.3 LTS Composer is installed: $ which composer /usr/...
1
vote
1answer
359 views

Update Drush in Docker4drupal

I have to upgrade Drupal core to 8.4 with Composer. Drush version is 8.1.12. I use Docker4drupal for my local development environment. How do I update Drush to 9 within my docker container setup, so ...
1
vote
3answers
99 views

Remotes: Can a local Drush 8 be used to send commands to a remote Drupal 8.4 site which includes Drush 9?

Let's say we have a dev-ops administrator who isn't a developer and doesn't want or (normally) need a local copy of the website. As of Drupal 8.4, Drush 9 is required, and Drush 9 doesn't have a way ...
1
vote
1answer
1k views

Config import constantly showing configs to import

Recently after doing a config import via drush (drush cim sync), the config files don't seem to import properly, as the files are listed after a supposed successful import. (and doing a cex sync shows ...
1
vote
0answers
17 views

What does the code status “build: error” signify for Drush 8?

On the install page for Drush 8, under the section "Drupal Compatibility", the code status is listed as "build: error". What are the consequences of this, if any?
1
vote
1answer
954 views

error on CLI when using drush config-import staging

I'm getting this error below whenever I try executing the commands drush config-import staging on the CLI. I'm basically in the process of migrating a drupal 7 DB to Drupal 8 and currently following ...
1
vote
0answers
1k views

Could not open input file: drush.php

I have installed drush usnig composer by using following command in my windows 10 machine: composer global require drush/drush After that if I run below command in my drupal project folder using ...
1
vote
0answers
1k views

Drush 9 on Windows 10 — some Drush scripts not found — but other Drush commands work

My environment: UniServerZ XIII (a form of WAMP server), Drupal 8.4.3, Drush 9.x, Windows 10 Pro. Used Composer to install Drupal and also for Drush (as a site install). Windows PATH (for local user) ...
1
vote
0answers
155 views

Why do I get this error?

I installed Drush with Composer and I get well the Drush version. drush cache-clear drush works too, but drush webform-libraries-make returns me the following error. The drush command 'webform-...
1
vote
0answers
65 views

There is a standard for the error codes in the drush_set_error() function?

I usually use the drush_set_error() function when I want to log a error in drush, sometimes I just do something like this: drush_set_error('DRUSH_INVALID_ARGUMENT', '....'); sometimes ...
1
vote
0answers
346 views

User feature export display errors

I am getting errors once export user feature. I have just export and put inside my module folder. Drush show below error: Symfony\Component\DependencyInjection\Exception\...
1
vote
0answers
87 views

PHP Fatal error while updating the UUID

I am getting the following error while updating the UUID with sudo drush config-set "system.site" uuid "d523bcdf-9d4b-45f4-9acc-a97ba4889b66" on Drupal 8.2.x. PHP Fatal error: Class Symfony\...
1
vote
0answers
485 views

Fatal error: Cannot redeclare composerRequireDrupal8()

I am using Composer and Drush. Everything was working smoothly, but after I installed the Panels module with Composer, I started getting the following error all the times I run Drush. Fatal error: ...
1
vote
0answers
103 views

Drush pm-list needs a higher bootstrap level to run

I am getting this error when trying to run pm-list. I am in the Drupal folder, not at the root, on Mamp Pro on my Mac using OS X El Capitan. I have tried setting the host from localhost to 127.0.0.1, ...
1
vote
0answers
418 views

Drush does not run remotely, SSH does not see Drush

I had Drush 4. Then I deleted Drush folder and installed Drush 8 through Composer for my user. Now drush command works on a server for my user. Then I try to invoke drush from my local computer it ...
1
vote
0answers
92 views

Upgrade from Drush 5->Drush 8, @sites stopped working. Bug or configuration issue?

All of this worked fine in drush 5.10. It is only since we jumped from the 5 branch directly to drush 8.1.10 that we have had the issue. The ultimate questions are: Is this a bug in drush 8 or a ...
1
vote
1answer
235 views

Unable to install lullabot/amp and sensiolabs/security-checker

i have installed amp and composer manager today i have been trying to get lullabot/amp installed, i have managed to install composer and drush on my computer but im not sure if they have been ...
1
vote
1answer
135 views

Drush is not recognizing Acquia extension

I am using Acquia and Drush 8.1.8. I am following Acquia's instructions to load Drush extensions and aliases. My ~/.drush directory looks like this: nickheiner@Nicks-MacBook-Pro.local:~/.drush λ ls -...
1
vote
0answers
284 views

`drush pm-update drupal` fails to copy to backup

Tried to update some of my Drupal 7 installation with drush. Some of them were successful while some were not. The error ones generate message like this: [foobar@server htdocs]$ drush pm-update ...
1
vote
1answer
604 views

Updating modules fails with XAMPP on Windows 10

I'm pretty sure I installed Drush 8 correctly on Windows 10. I ran the command window as administrator. I changed to my Drupal directory, but I get "Command pm-update needs a higher bootstrap level to ...
1
vote
0answers
294 views

remote Drush stops because of “ headers already sent”

I am struggling with a remote drush error since days, and don't find the cause. I already checked the Internet up and down for an answer, but could not find a solution for my problem (here,here and ...
1
vote
1answer
544 views

Installing a New Site with Drush and Ansible

I'm trying to create an Ansible Role to run on a VM that creates a new site (so my colleagues don't have to memorize the drush si --db-url command and automate the entire process. I'm running into a ...
1
vote
0answers
188 views

Drupal 6.37 to 8.2.x upgrade with drush fails with 1115 Unknown character set: 'utf8mb4'

I am upgrading a legacy Drupal 6.37 site running on mysql 5.1 to a fresh install of Drupal 8.2.1 with mysql 5.7.16 on a remote host. I have installed the migration modules required for drush and am ...

1
2
3 4 5
9