Questions tagged [updating]

Use it for questions about updating Drupal core and contributed modules.

Filter by
Sorted by
Tagged with
2
votes
2answers
4k views

How can I update core. all the modules, and the themes from the command line?

On a LAMP environment, I have a Drupal 8.5.6 site which is nearly all-core with the Bartik theme and a few stable contributed modules. Nothing is customized and I have daily backups so I don't "...
0
votes
1answer
415 views

How do I use Hook_update_N to update an FieldConfigStorage?

function some_config_update_8101(){ if ( !FieldConfig::load('image_byline') ){ $config_path = drupal_get_path('module', 'some_config') . '/config/install/field.field.node.main_image....
3
votes
2answers
2k views

Drupal\Component\Plugin\Exception\PluginNotFoundException: The “<whatever>” plugin does not exist

After updading a Drupal site from 8.6.16 to 8.7.1 (PostgreSQL 9.6.13 , Nginx) I get this error in almost every operation (creating a view , installing a module, creating a content type, creating a ...
0
votes
2answers
738 views

Drupal database not found after running update.php

after installing a module I run update.php and then click take me to front page or take me to admin pages the page takes a while to load and eventually gives me the following error: PDOException: ...
0
votes
1answer
594 views

How update programmatically node entity with empty field_image?

i need to make an import from one mysql table in my base. I create node with : $value= array( 'type' => strtolower($typeProduit), 'field_1'=>"test", ...
0
votes
1answer
624 views

Error while accessing admin section

I am facing the following error while trying to access Admin section in Drupal 8 (WAMP Server). I tried to install the Update manager module and from then I am facing this error. I am unable to access ...
0
votes
1answer
432 views

Error after copying the updated files

I want to update a site from Drupal 8.9 to 9.0. After copying all files and trying to execute update.php, I get the following error: The website encountered an unexpected error. Please try again ...
2
votes
1answer
805 views

Unable to Update to latest core

Update from 8.5.0 to 8.5.1 is failing on one of my drupal instance. >composer update drupal/core --with-dependencies Loading composer repositories with package information Updating dependencies (...
0
votes
2answers
1k views

How do I use an older jQuery version?

Drupal 8.5 requires jQuery 3, which has some site breaking features. I would rather like to use version 2.2.4. I have tried the libraries-override approach suggested in How do I use a jQuery version ...
0
votes
1answer
630 views

Update script fails due to Service capacity

I am trying to update the core of my Drupal site. I neglected updates for some time and the update script had 19 updates pending. Apperently the update script tries to do all of this in one go, and ...
1
vote
0answers
53 views

Upgrading core from 8.7.10 to 8.9.16

My current site version is running on Drupal 8.7.10 and I want to upgrade it to 8.9.16. I backed up all the files and folders. Should I backup the Pathauto module, update the new Pathauto module, and ...
1
vote
0answers
29 views

Update installs a beta version [duplicate]

I'm trying to update Drupal from 9.1.8 to 9.1.9. However, running a composer update jumps to 9.2-beta2. I'm not sure how to fix it so that it sticks to the recommended version. My composer.json has ...
8
votes
5answers
4k views

Cannot update: “No available releases found”

I cannot update some of the modules and the Drupal core itself from "Available Updates" menu. The error is "No available releases found". However, I can list the updates with drush ups. Why?
3
votes
2answers
88 views

When “drush updatedb” is executed, are scripts cached by OPCache invalidated?

For sites that have PHP OPCache enabled: Does updating site using Drush require restarting the webserver to invalidate the scripts cached by OPCache? Does Drupal core or Drush invalidate OPCache ...
17
votes
5answers
7k views

What is the correct core update workflow?

I want to use composer to manage Drupal 8 dependencies, but I'm not sure what is the right core update workflow. At the moment I'm using drush to update core to latest beta release, but I also have ...
-1
votes
1answer
837 views

How can I fix this update issue?

I have updated a Drupal site from 8.5.3 to 8.6.3 and got the following error related to the webform module. Can anyone help me fix this? webform module Update #8108 Failed: Drupal\Core\Database\...
3
votes
0answers
178 views

What is the best practice for handling abandoned packages required by the drupal core?

When I run composer update on a Drupal 9 website, I get this warning: Package doctrine/reflection is abandoned, you should avoid using it. Use roave/better-reflection instead. A similar question has ...
0
votes
0answers
21 views

Swiftmailer prevent composer updates

I have an issue with composer and Drupal 8.9.13. When I try to update Drupal, I always get the next error and I don't find a way to solve it: #$> php -d memory_limit=-1 composer.phar update drupal/...
1
vote
2answers
471 views

Updates for custom module not showing in update.php list

I've created a custom module for my Drupal 7 website, under sites/all/modules/custom/tm_general which has the following updates in the tm_general.install (please see image attached). The site is ...
3
votes
1answer
7k views

Updating core to a specific version with Composer

My site hasn't been updated for two months, a few new updates has been released. My site's core version is 8.5.6. Before running composer update -with-dependencies I read the release notes to the ...
0
votes
0answers
23 views

Adding a new view to an existing module

I am trying to add a new view to an existing module. I created the view using Views UI and exported its YML to the 'config/optional' folder. If I install the module for the first time, the view is ...
12
votes
4answers
5k views

Resetting/reverting a custom module's update 'N value'

In my custom module's install file I have a hook_update_N function. Let's say it's mymodule_update_7100. However, I've noticed that I've done it wrong and I want to change a line of code within this ...
2
votes
1answer
51 views

Which releases are supported with semantic versioning of modules?

I have a site running Drupal 8.9.13. I have enabled email notification for "only security updates" and it generally works well - I get a mail for "urgent things" otherwise I wait ...
0
votes
0answers
435 views

Update error and Basic Auth / Symfony errors

I'm running 2 servers: TEST and PROD. I've been using Composer to install updates. They are running on Windows Server 2016 using IIS. I copied composer.json and composer.lock from TEST over to PROD. ...
0
votes
0answers
24 views

Issues with manual update from 7.77 to 7.78 on cPanel with PHP 7.4

I have been manually been doing Drupal 7 and 8 updates on cPanel for many years. I carefully read what files need to be updated and what files need to stay. Recently, there was an update to PHP 7.4. I ...
0
votes
0answers
34 views

After the update 8.7.14 to 8.8, the File module causes error when uploading a file

After updating Drupal 8.7.14 to 8.8, I have a problem with the File module: When I upload a file, I get the This value cannot be zero error message. The file is however present in the site/default/...
0
votes
1answer
40 views

Cannot disable module “monitoring” after failed upgrade

I just updated to Drupal 8.8.1 (composer update drupal/* --with-dependencies now says I'm up to date, even though I know that 8.8.2 is actually the most recent). After doing this, I can use most of ...
0
votes
0answers
81 views

Failed to update database after upgrading to 8.9.13

I'm new to drupal and was recently tasked with upgrading the drupal core version of one of our sites. I upgraded from 8.3 to 8.9.13 and everything went smooth enough until it came time to update the ...
0
votes
0answers
55 views

upgrade from 8.9.2 to 9.1.0

I have a drupal 8.9.2 installation with many modules. I ran upgrade_status and applied patches or upgraded modules to dev version like suggested. fhebert@fhebert-communication:/var/www/domain.com$ ...
1
vote
0answers
47 views

Updating modules creates An AJAX HTTP request terminated abnormally error

Drupal 7.77. I have three modules that need to be updated. Trying to update any one of them results in this error: An AJAX HTTP request terminated abnormally. Debugging information follows. Path: ...
0
votes
0answers
401 views

Issues updating core to 9.1.2 with Composer

On my local site, I had updates for 2 modules and Drupal core. To update, I typed in composer update, which had worked for me previously just fine. Composer indicated everything updated, although on ...
1
vote
1answer
4k views

Composer shows “nothing to update” but there is a new version of the module

I am managing a Drupal 8 site in Composer. Commerce 2.0 was just released; I currently have 2.0-rc2 installed on my site. This is my composer.json "drupal/commerce": "^2.0@RC", &...
0
votes
0answers
51 views

PHP Error occuring when updating, clearing cache or install/uninstall modules?

I am getting this below error when doing the actions of clearing cache, or install/uninstall module, running update.php. InvalidArgumentException: Routing requirement for "_user_is_logged_in"...
1
vote
1answer
344 views

Checking Available Update data - AJAX error

I'm having problems with a local site that I imported to Acquia Dev desktop from one of my live sites. Everytime I try to Check for Available Update data, I get an Ajax error Error Checking Update ...
4
votes
1answer
36 views

List module releases that are “Recommended by the project’s maintainer.”

On the project page of a Drupal module there is a list of releases. The project owner can set for each one whether it is recommended, and the page displays that fact. For example if there are ...
0
votes
1answer
19 views

Fatal error: Cannot redeclare uc_order_views_data()

After clicking Continue @ /update.php, we receive: Fatal error: Cannot redeclare uc_order_views_data() (previously declared in /home/user/public_html/sites/all/modules/ubercart/uc_order/views/...
0
votes
0answers
23 views

Unable to access Admin page after core update (minor version 7.? to 7.77)

After manually updating Drupal 7 core - I am unable to access the /admin or /user page. Here's my process: backed up db entered maintenance mode manually downloaded Drupal 7.77 (deleted default '...
2
votes
2answers
3k views

Composer update - Your requirements could not be resolved to an installable set of packages

when I run a composer update --with-dependencies, I get the following error message: Problem 1 - don't install drupal/core 8.6.0|remove drupal/drupal dev-master - don't install drupal/core 8....
0
votes
0answers
31 views

I updated a contributed module in error

I updated Panels in Drupal 7, forgetting that I had customised it, panicked, deleted the updated module and replaced the correct one via ftp. Now I can't run update.php as it says the website ...
13
votes
8answers
6k views

Drush does not acknowledge release of new core update

I am trying to update my drupal 7.31 core to 7.32 via Drush. I ran the following commands $ drush pm-releases Project Release Date Status drupal 7.x-dev ...
1
vote
2answers
304 views

Updating from core 8.7.9 to 8.8.0

I'm running into an issue when updating to Drupal core 8.8.0. I've removed both the vendor folder and the composer.lock file, as per instructions on this link https://www.drupal.org/node/2700999#s-...
0
votes
1answer
611 views

Problem upgrading via Composer

I am currently trying to upgrade my site from drupal 8.9 to drupal 9. I ran these commands to give permissions: $ chmod 777 web/sites/default $ find web/sites/default -name "*settings.php" -...
3
votes
1answer
61 views

Why is the output from getDefinition($type) different from getStorage($type)->getEntityType()?

In a Controller, when calling: $this->entityTypeManager()->getStorage($type)->getEntityType(), I do not have the exact same return value as: $this->entityTypeManager()->getDefinition($...
0
votes
0answers
38 views

How do I solve this issue while upgrading using Docker compose?

I have already deploed drupal 8.7.7 using docker. now am trying to upgrade to 8.9.7. during the site installation i am facing below error " In SiteInstallCommands.php line 335: Could not ...
1
vote
1answer
148 views

How can I update the name of a taxonomy term using hook_update_N?

I have taxonomy terms of color and I made a typo in one of the color name. It should be 'Crystal Black Pearl' instead of 'Crsytal Black Pearl'. How do I change it using hook_update_N ? Thank you in ...
1
vote
1answer
265 views

Missing updates for Media

After much package dependency finagling via composer, updating PHP, updating MariaDb, etc.. (not as bad as D7 => D8 but still harder than I'd hoped) I managed to update from 8.9 => 9.0.7. I was ...
0
votes
1answer
53 views

Failure in “file module Update #8700”

file module Update #8700 •Failed: Drupal\Core\Field\FieldException: Field storage definition for 'type' could not be found. in Drupal\Core\Entity\Sql\SqlContentEntityStorageSchema->getEntitySchema(...
0
votes
1answer
301 views

Updating core to 8.9.6 fails

I'v installed Drupal 8 by composer. Everything worked fine, but when I tried to update core from 8.9.1 to 8.9.5 in ended up in 8.9.4. Today I tried to update from 8.9.4. to 8.9.6 by changing composer....
6
votes
3answers
4k views

How can I install a specific core version?

Composer always installs the latest version of Drupal core, but I want Drupal 8.6, not Drupal 8.7. How can I install a specific core version?
2
votes
1answer
150 views

How the handle an override of the schema of a field type

To add other data to a state field, I overrode 2 functions of the StateItem class (from the state_item module) public static function schema(FieldStorageDefinitionInterface $field_definition) { ...

1
2 3 4 5
14