Questions tagged [updating]

Use it for questions about updating Drupal core and contributed modules.

Filter by
Sorted by
Tagged with
2
votes
1answer
1k views

Drupal\Component\Plugin\Exception\PluginNotFoundException after upgrading drupal

I tried to upgrade from version 8.0.x to 8.1.x. I used drush with the command drush up drupal. The output shows some errors: Do you wish to run all pending updates? (y/n): y The "...
0
votes
1answer
54 views

Additional old_XXXXXXtaxonomy_term__field_XXX Tables after upgrading

After Upgrading from Drupal 8.6 to 8.7 I have tons of new (garbage?) tables in the database. The naming schema for the tables is old_XXXXXXtaxonomy_term__field_XXX Is there a drush command to remove ...
0
votes
0answers
64 views

Is it possible to make a site aware of entity schema changes that are managed externally using SQL-based storage?

Consider the following situation: A Drupal 8 site using native SQL-storage (MySQL) custom_table is added to the same MySQL host as Drupal, either as a table in the Drupal system DB or as a table in a ...
0
votes
1answer
34 views

Drupal update to specific version (not dev) with git

I have a Drupal folder made with command: git clone --branch 7.x https://git.drupalcode.org/project/drupal.git Now I want to update it to the actual version (7.67). When I run git pull origin 7.x ...
4
votes
3answers
2k views

Site not working after the database update

I cloned a repo of a site to my local computer, imported the database and ran "Composer install --with-dependencies" after the installation had been done I entered the local site and it worked, then I ...
1
vote
1answer
25 views

Core updates and module updates: Does order matter?

I inherited a badly out-of-date Drupal 6 multi-site instance. There is only the production instance. (yeah, that gives me a warm-fuzzy!) Many modules are several versions behind and the core is ...
0
votes
1answer
40 views

How to generate my own patches to update core for security when fuerstnet.de's “Drupal upgrade the easy way” page is out of date?

For Drupal 7, under the current host I'm using (which doesn't provide things like drush), I've found that patching is the easiest approach to updating core. However, the commonly-referenced page which ...
-1
votes
1answer
39 views

Drupal maintenance over several environments [closed]

I have a production environment for a Drupal 7 site. This environment is replicated to a staging environment, which we use for testing updates to modules and drupal core (same major version). We ...
-1
votes
1answer
1k views

Why do I get this error when running update.php?

Attempting to update drupal 8.0 to 8.1, when I run update.php, I receive this error: An AJAX HTTP error occurred. HTTP Result Code: 500 Debugging information follows. Path: /update.php/...
0
votes
1answer
488 views

Why can't I update core from 8.6.16 to 8.7.1?

I need to update my Drupal 8 site from 8.6.16 to 8.7.1, but when I run composer update drupal/core --with-dependencies it says "Nothing to install or update". I have been banging my head on the wall ...
1
vote
2answers
100 views

Can I remove the experimental module warning from /admin/reports/status?

My drupal 8 site is showing a experimental modules enabled warning under /admin/reports/status. I vaguely remember to have them enabled at a certain time, but I forgot where. I don't use any of them, ...
0
votes
1answer
95 views

Drupal 8: Node “options” does not exist for Node “Drupal\Core\Template\TwigNodeTrans” error after update

after updating Drupal 8 from 8.6.14 to 8.6.15 (twig v1.40.1) I suddenly get this kind of fatal errors: Uncaught PHP Exception Twig\Error\SyntaxError: "An exception has been thrown during the ...
0
votes
1answer
31 views

How do I apply or run an update?

For recent changes to 8.5.x, my paragraph entities broke and throws the following error. SQLSTATE[42S22]: Column not found: 1054 Unknown column 'revision_uid' in field list I uninstalled and ...
2
votes
2answers
72 views

How do I resolve an unnamed requirements problem during an update?

I am attempting to update my Drupal 8.2 instance to Drupal 8.6.4. I have faithfully followed the manual installations steps found here https://www.drupal.org/docs/8/update/update-core-manually. I ...
1
vote
1answer
187 views

Composer.json deletes dir even with preserve path

I am running composer on Drupal 7 and I am just trying to update my site; however when I run composer update, the composer deletes all the preserve paths I had specified. My structure is as follows: ...
0
votes
1answer
123 views

Wrong status after updating from 7.64 to 7.66

I recently manually updated my localhost drupal site from 7.64 to 7.66. I ran update.php without errors. When the process finished, I cleared all cache and checked the status. It still reported 7....
0
votes
0answers
44 views

Update Symfony before Drupal core?

Right now there are some security updates for Symfony: curl -sS https://get.symfony.com/cli/installer | bash echo y | ~/.symfony/bin/symfony self:update ~/.symfony/bin/symfony security:check Symfony ...
0
votes
3answers
442 views

How does Drupal know when to run an update script?

How does Drupal 8 know what module needs updating and to what version he needs to update? I have build a module and I'm trying to update it (adding a table). I implemented a update hook numbered 8001,...
0
votes
0answers
55 views

Should I not update from 8.4.2 straight to 8.6.13?

Due to someone leaving the company I work for I was handed the "webmaster" duties of a website hosted off-site running on Drupal 8.4.2. When I first logged in to the admin panel I discovered a host of ...
0
votes
1answer
91 views

updates page shows an error for a mystery module 'standard 8.6.12'

on the updates page /admin/reports/updates under Modules there is a module called standard 8.6.12 as and it is highlighted with a warning No available releases found (Warning) this module does not ...
0
votes
1answer
274 views

Change target type of entity reference field in update hook

In an update function, I'm trying to change the target_type of an entity reference field, following the approach outlined on https://www.drupal.org/node/2535476). The previously used target entity ...
1
vote
2answers
463 views

composer won't update 8.6.13

I can't update Drupal 8 from 8.6.10 to 8.6.13 -- please help! composer.json -- partial "require": { "composer/installers": "^1.0.24", "wikimedia/composer-merge-plugin": "^1.4", ...
2
votes
2answers
1k views

Some of the pending updates cannot be applied because their dependencies were not met

I have a Drupal 7 site that is giving me the above error. I cannot for the life of me, figure out what dependency needs to be met. And I can't not remember what I did, or if I did anything, to cause ...
0
votes
2answers
1k views

Core doesn't update with Composer

We use commands: composer outdated drupal/* drupal/core 8.6.10 8.6.13 Drupal is an open source content management platform powering millions of websites and applications. It does show 8.6.13. We ...
0
votes
1answer
256 views

Why does updating break my site?

I have a site running Drupal 8.6.10. I installed it with Composer: composer create-project drupal-composer/drupal-project:8.x-dev JdP8M7b --stability dev --no-interaction I tried to update it to 8.6....
1
vote
3answers
4k views

Error 500 on accessing update.php [closed]

Long ago I got a message about updates to my modules. I've updated the modules. But I received a message to update the database. I want to run the update.php script but I encounter the following ...
0
votes
1answer
253 views

No Available release found

On the module update area, my install of 7.56, can seem to find matches to core and a few modules. How do I begin to fix this? What I've tried so far: Based on translating an answer in Cannot ...
34
votes
2answers
24k views

How to switch from recommended release of module to dev release?

For example, I'm currently using the Geofield module. I'm using version: 7.x-1.0-beta2 (2011-Nov-17) Now I see the development version has some functionality that I want. How do I correctly and ...
1
vote
0answers
625 views

Composer update drupal core problem [duplicate]

I've inherited a site that I'm attempting to update - and when I attempt to update to the newest security patch - composer tells me that: composer require drupal/core:8.6.10 ...
1
vote
2answers
239 views

xmlrpc() error: (-1001) unable to parse URL during Drush command

I have an odd error coming from Drush when I perform module updates and other commands (it's most consistently comes from module updates). Near the end of the command execution this message pops up: ...
0
votes
1answer
52 views

backing out of a module update after uploading it and before the database update (new update is incompatible with my version of PHP)

I got a situation here and I don't know what to do. Drupal 7. There's an update for reCAPTCHA so I click the button and checkboxes and whatever to update it, it uploads the files to the server and ...
0
votes
0answers
388 views

Unable to determine class for field type during upgrade

I'm getting the following error when I am updating my site's core and contrib modules. I'm at a loss as to how I would go about finding the issue. I've gone to views.views.inc line 181 and looked ...
1
vote
2answers
1k views

Error updating modules with composer

I'm trying to update a module with composer. This is the command (but it the same if I try to update another module): composer update --with-dependencies drupal/geofield_map This is the output of ...
2
votes
1answer
2k views

Why am i getting this Drush error after updating a site? [closed]

I use Drush 8.1.17 to update my Drupal 7 sites, and as I have been updating my sites today after the latest security update I have noticed that after I update a site if I try to run any update related ...
1
vote
0answers
67 views

Distribution Commerce Kickstart 1.x - is possbile run Drupal Core 7.61 / PHP 7.2 ? And how [closed]

I have small and very simple Drupal 7 site based on Commerce Kickstart 1.x distribution (originally instalation profile, now "distribution"). The version of distribution is 7.x-1.53. It is last ...
0
votes
0answers
334 views

What to do when Drupal can't check for updates? [duplicate]

I am trying to check for updates using the core update module but I keep getting this error: There was a problem getting update information. Try again later. I am checking from /admin/reports/...
0
votes
1answer
123 views

Refresh default migrations

I done a migration of a website, but new content were created during I done that. So how can I refresh default migrations created by the drush command : drush @alias migrate-upgrade --legacy-db-url=...
0
votes
1answer
96 views

Is it necessary to clear site caches after putting site into maintenance mode?

I enabled maintenance mode on a Drupal 7 site; however, when I checked the homepage as an anonymous user, I noticed that the original homepage was still being displayed rather than the maintenance ...
4
votes
1answer
464 views

Custom blocks not rendering for anonymous users

I recently deployed an update to Drupal 8.6.3 from 8.6.2 on our Drupal-specific managed web host (Pantheon). Unfortunately, I noticed after the update that our site's footer was missing, but only ...
1
vote
1answer
640 views

How to update the database schema without losing existing data

I have a custom module with my_module.install file defining my two data tables in mysql. Module is already installed and I am able to save data from forms into them. Now my requirements changed and I ...
1
vote
1answer
184 views

How to update a node after loadByProperties? [closed]

I search for a node with field value client id and I need to update values. How do I do that in drupal 8? I search with the following code $profileNode = \Drupal::entityTypeManager() ->...
2
votes
1answer
446 views

Updating core from 8.5.4 to 8.6.3, can I skip the releases in between?

I have a website that is running on Drupal 8.5.4. I want to update it to Drupal 8.6.3 through the manual update option (link). Can I directly update it to 8.6.3 skipping the releases in between? ...
0
votes
1answer
56 views

Disable third-party modules before core update

I have a D8 (8.5.6) installation which I have been trying to upgrade to 8.6 since it came out. It is on a shared hosting account which does not allow drush, so FTP it is. During the database update, ...
0
votes
1answer
101 views

How to use drush locally with Acquia Dev Desktop2 and upgrade core

I just a new project in Drupal 8 and it's hosted on Acquias cloud using Dev Desktop 2 (DD later on). Now the project is working fine, but i can't use drush at all, as the settings.php is generated by ...
18
votes
5answers
6k views

Is it possible to force your module's update hook to run?

I am the author of the Date iCal module, and the new major version I'm working on (3.x) requires a two-part schema update for users who had 2.x installed. I've written the update hook that makes these ...
0
votes
1answer
44 views

How to add a column to DB with weight by using hook_update_N?

I want to add a column to a database by using hook_update_N(), but it should be 3rd column instead of last column. How I can achieve that please help in this regard. I tried to add weight but not ...
-1
votes
2answers
85 views

I am trying to update my site to 8.6.3 and I receive the following message

When I try to update Drupal to 8.6.3 i receive the message CONFIGURATION DIRECTORY: SYNC The directory drupal-8/sites/default/config_acq does not exist. I don't know what to do. Please help me
1
vote
1answer
113 views

The pdf_thumbnail plugin does not exist

After I tried to update the database I got the following error: Failed: Drupal\Component\Plugin\Exception\PluginNotFoundException: [error] The "pdf_thumbnail" plugin does not exist. in ...
2
votes
1answer
70 views

“Experimental modules found: Place blocks” but I am using core 8.6

I am using Drupal 8.6.2. When I open the status report I see the following warning: Experimental modules found: Place Blocks. Experimental modules are provided for testing purposes only. Use at ...
0
votes
0answers
407 views

How can I tell Drupal to skip a failed DB update instruction?

when updating from 8.5.x to 8.6.1, an error happened when running one of the database update instructions. More precisely, the error occurs when Drupal is trying to run function taxonomy_update_8502()....

1 2
3
4 5
14