Questions tagged [updating]

Use it for questions about updating Drupal core and contributed modules.

Filter by
Sorted by
Tagged with
9
votes
3answers
4k views

Automatically update Drupal core/modules for a large number of sites (with Drush)? [closed]

I'm the administrator of a lot of Drupal websites on different hosting providers. Some have drush; others don't (and can't: like shared hosting). Every time there is a Core upgrade, I spend 1 or 2 ...
0
votes
2answers
2k views

When I update my database schema with drush entity-updates. I get an error

When I try to update my database Schema I'm getting the following error: Drupal\Core\Entity\Exception\FieldStorageDefinitionUpdateForbiddenException:[error] The SQL storage cannot change the ...
0
votes
1answer
757 views

Updating core from 8.4.4 to 8.6.1

I want to update Drupal from 8.4.4 to 8.6.1. I've tried to follow the steps from this page, but without success. When I run this command: composer update drupal/core --with-dependencies I get: ...
1
vote
1answer
123 views

What is the best way to update Drupal periodically using a cron job? [closed]

Previously I periodically updated Drupal sites by using a cron-job with a "drush up -y" script running every Wednesday 15,16,17,18,19,20,21,22 hours UTC. which is when "Security releases happen" ...
2
votes
2answers
3k views

How to update core and all modules and themes from CLI?

On a LAMP environment I have a Drupal 8.5.6 website which is nearly all-core with the Bartik theme and a few stable contrib modules. Nothing is customized and I have daily backups so I don't "fear" of ...
0
votes
1answer
1k views

drush updb fails with “the 'media_delete_action' plugin does not exist” after 8.4.6 > 8.5.1 update

We have recently updated a Drupal 8.4.6 installation via composer to Drupal 8.5.1. After the composer update I ran drush updb as usual. However, the command fails at one point with the following ...
2
votes
1answer
286 views

Core update installs 8.6.0-beta1 instead of 8.5.6

Using composer I tried to update Drupal 8 to 8.5.6. The update wasn't working, so I changed the dependencies to explicitly require 8.5.6. The update began, but it installed Drupal 8.6.0-beta1. The ...
0
votes
1answer
31 views

After Update to 8.5.6, “Add” Links Missing From Page but still are in router

I recently manually updated Drupal to the 8.5.6 version. I did this by moveing over the files (using command line) according to Drupal.org instructions and running update.php. I have two issues that ...
0
votes
1answer
883 views

How do I use an older jQuery version?

Drupal 8.5 requires jQuery 3, which has some site breaking features. I would rather like to use version 2.2.4. I have tried the libraries-override approach suggested in How do I use a jQuery version ...
1
vote
2answers
459 views

8.5.6 Update not being recognized

I converted a Drupal 7.xx site to Drupal 8.x manually. Updated it to 8.4.5 and tried to use composer to update it to 8.5.6 (Latest stable release). I have the original site as the public_html/drupal ...
3
votes
1answer
26 views

What argument to pass hook_update_n()?

We have a custom module, mymodule, that we are using to create a custom block programmatically. We tried to do the following and it does enable the module successfully, but i get the following warning....
0
votes
0answers
93 views

Can't access the Status Report page

I've updated my LOCAL site with composer, updated the database but can't access the Status Report page (site encountered an unexpected error). I looked at the recent log messages and saw this error: ...
-1
votes
1answer
83 views

Updating manually with CPanel

I've updated my local site with composer. Now I'm trying to update the production one: Go to Cpanel. On my local computer, take the local web folder and delete in it all 1-level files that are non-...
3
votes
1answer
186 views

Composer package is updated, but core still asks to update

I am using Drupal 8.5.5. On admin/modules/update I red the following message. Bootstrap (Theme) Bootstrap (Theme) 8.x-3.11 update to 8.x-3.12 (Release notes) The composer.json contains the following ...
1
vote
1answer
189 views

The missing phpmailer module

I updated a site with "Composer update --with-dependencies" and encountered the following problem: User warning: The following module is missing from the file system: phpmailer in drupal_get_filename(...
10
votes
4answers
3k views

How to update disabled modules using Drush?

Is there a way to update disabled modules with Drush? Currently, when I try to update a disabled module with Drush, I get this message: Project has no enabled extensions and can't be updated ...
1
vote
2answers
438 views

How to prevent “drush up” from destroying my git repo

I just updated Drupal to 7.39 using Drush, in particular the command drush up and all related steps as explained here: https://www.drupal.org/node/2550801. During the update I have noticed this ...
0
votes
1answer
881 views

How to update from Drupal core 8.5.0 to 8.5.5?

In the past (Drupal 7), security-only update via drush was simple as: drush up --security-only now, Drush 9.3 returns: Command "up" is ambiguous. Did you mean one of these? ... composer does ...
0
votes
0answers
109 views

Site doesn't see available updates

I checked for available module updates on my non-production site and the site returned: "All of your projects are up to date." But I know for sure that some of the modules are outdated, hence the site ...
12
votes
7answers
5k views

Drush does not acknowledge release of new core update

I am trying to update my drupal 7.31 core to 7.32 via Drush. I ran the following commands $ drush pm-releases Project Release Date Status drupal 7.x-dev ...
-1
votes
1answer
82 views

How to always run hook_update_N automatically, regardless of the 'N' value?

I need to run a specific command after each update of a certain module. Is there any way to use hook_update_N without having to update the N for each version? A hook_update_always solution? The use ...
1
vote
1answer
338 views

Drupal incorrectly reporting that permissions need to be set on settings.php

I've updated a site to v8.5.3. Checking the status report I have various messages. One says: Not protected Protection disabled - The file sites/default/settings.php is not protected from ...
4
votes
1answer
1k views

Should a site be in maintenance mode when running the Drush Up command?

I'm not asking if I can update my website with Drush. I'm not asking if Drush can make it in maintenance mode. My question is ... if I'm using the command drush up to update my Drupal core or a ...
0
votes
1answer
46 views

install.php displayed instead of update.php

This looks similar to Drupal 7 keeps returning to install.php and reports no settings.php but it's all there but I only just registered so can't comment. This is a single site (still drupal 7....
2
votes
2answers
223 views

Composer does not install Calendar Module

Hi I am having trouble migrating my local site to development (two seperate servers). I believe the reason being is because I can not install an unstable Calendar Module, which I have on my local but ...
1
vote
2answers
641 views

status report asks me to run update.php but getting 'no pending updates'

I'm on core version 7.58. My status report says "Some modules have database schema updates to install. You should run the database update script immediately." But when I run update.php (or drush ...
3
votes
2answers
2k views

The update.php doesn't want to run it's complete course [closed]

I updated core Drupal (D7.14) and all seems to running perfectly. Only some updates for the database are required. So I run the update.php and I get through the first stages and I can see the pending ...
2
votes
1answer
2k views

Installing an alpha dev version with composer

Block class module has a 8.x-1.x-dev version. Installing using the recommended command from the specific release page composer require 'drupal/block_class:1.x-dev' installs a versionless ...
-1
votes
1answer
114 views

Best Practices for Acquia: Reconciling Production Database back to Dev before update; what is the workflow?

In about a week, I have to update several production sites hosted in AcquiaCloud environments to 8.5.3. All of these sites receive frequent real-time DB writes from user-submitted content. I can ...
1
vote
0answers
59 views

How to fix getlabel() error?

So I had to update a size of a field and I used an update hook. However, in my update hook I deleted the field and the index and added the field again with the updated size. Now when I go to the ...
1
vote
2answers
64 views

How to monitor several sites for updates from one central site?

I have several Drupal sites and wish to have one site list all of their "status" and available updates. So to start with I am trying to find how to get the available updates. The central site has ...
2
votes
4answers
7k views

How do I update core to 8.4?

I checked the other questions related to this topic, but half of them didn't get any useful answer and the other half didn't help me out. I face with several issues building up a site using Drupal 8: ...
0
votes
0answers
31 views

Last update filter

I'm developing an application that will access Drupal using services and one of the parameters used is the date, I used the filter "Content: Updated date (Updated date)" but instead of giving me just ...
1
vote
0answers
32 views

How to update node fields via twilio sms reply from node author?

I have been working on this for a while now, but I am still struggling to wrap my head around it. I am using Drupal 7.x with Views, Rules, Views Rules, Twilio and Services to try and achieve this. ...
0
votes
0answers
178 views

Error after updating to latest core version [duplicate]

After Drupalcon last week I felt comfortable using composer, and I was ready to update our site from 8.4.6 to 8.5.1. I have done just that (luckily in a dev environment) and now the front page of the ...
3
votes
2answers
3k views

How to apply database updates once the module is installed and after a new entity has been created?

I have installed custom module. Then created entity: content type with drupal generate:entity:content Now, I'm trying to update the module, so that the entity is installed, but no clue. Since code ...
2
votes
1answer
247 views

Why doesn't core get updated to 8.5?

I am trying to update via Composer following what reported in Update core via Composer, but when I do composer update drupal/core --with-dependencies, I get the following output. Loading composer ...
0
votes
1answer
1k views

How do I update core to 8.5?

After I realized that the thing I mostly enjoyed using Drupal for the last 10 years, Drush, is being axed, I started to set up all new Drupal sites with Composer. Unfortunately I can't update core as ...
0
votes
0answers
70 views

Updated to 8.5.1, but front end says 8.5.0 is installed

I did the update from 8.4.5 to 8.5.x with Composer. I had some issues, but finally got it to work. Now, if I do drush status It says Drupal version : 8.5.1 If I look at the version listed in ...
0
votes
0answers
234 views

Drush silently fails to update core drupal 7 installation - why?

For some reason, drush is reporting successful upgrade of a core Drupal installation from version 7.56 to 7.58, however it is only partially doing the job! See below. Only updates a few files, should ...
1
vote
0answers
175 views

Updated to 8.5.1 but front end still says 8.4.4 installed

I have been going through and updating my drupal sites after the announcement of CVE-2018-7600. All have gone smoothly except for one site that was running Drupal 8.4.4 I updated the site following ...
0
votes
3answers
259 views

Drush error on core update “corrupt (wrong md5 checksum)”

I'm getting this error when I try to update core with Drush: File drupal-7.41.tar.gz is corrupt (wrong md5 checksum). [error] Updating project drupal failed. Attempting to roll back to previously ...
0
votes
1answer
31 views

Custom Module Remote Fails Checksum with Drush

Background I have several proprietary Drupal modules that my company uses. We want to update these across all our sites. To that end, I've built an endpoint that produces code according to the (ill-...
0
votes
0answers
228 views

"The website encountered an unexpected error. (WSOD) Service 'twig_extensions.twig.array' for consumer 'twig'

I have an Acquia Cloud hosted site built on Drupal 8.4.3. Using Acquia Dev Desktop and Drush, I updated a local development environment to Drupal 8.4.5. Immediately after Drush updated the site, I ...
0
votes
1answer
130 views

aborted prematurely while running update #7204 [closed]

I get this message but nothing is logged (that I can see) The update process was aborted prematurely while running update #7204 in wysiwyg.module. All errors have been logged. You may need to check ...
1
vote
1answer
828 views

Unable to run database updates via Drush - Call to undefined function batch_get()

Having some difficulty running database updates via drush after updating modules in the codebase. This is the error that is being reported: Error: Call to undefined function batch_get() in /root/....
1
vote
2answers
88 views

Is it possible to individually update each module using update.php?

I am trying to update the reCAPTCHA module (which is installed on sites/all/modules) in Drupal 7. I could see other 3 modules which have pending updates. Is it possible to individually update each ...
0
votes
1answer
168 views

Update problems when updating to Varbase

I updated a Drupal 8 site to Varbase release 16. After running update.php I get the following error. Symfony\Component\Routing\Exception\RouteNotFoundException: Route "content_lock_timeout....
0
votes
0answers
524 views

Enable SFTP for upgrades

After installing D8 on my server, I wanted to add some modules, so I went to Extend / Install new module and was told I needed FTP access to the server. I've got my server configured to only use SFTP,...
-2
votes
3answers
515 views

How do I update to latest version? [closed]

I used drupal-composer/drupal-project to install Drupal 8. Drupal 8.4.7 was installed, and the website was functioning as expected. Today, I got the message that Drupal 8.5 was ready for prime time, ...

1 2 3
4
5
14