Questions tagged [updating]

Use it for questions about updating Drupal core and contributed modules.

Filter by
Sorted by
Tagged with
0
votes
1answer
449 views

Drupal 8 update via drush removes files from vendor folder

I recently made a core update with drush for D8. After the update I saw that it removed a folder from the 'vendor' folder on the server? Why did that happen? The module has been installed via ...
28
votes
6answers
22k views

drush updatedb for a single module

Is it possible to perform a single module's update function via drush? I can see drush updatedb which does not take an modulename as argument and runs all available updates. Then there is drush pm-...
18
votes
10answers
26k views

What are my alternatives to disable update notifications but without using module Update Notifications Disable?

I need to disable the update notification overall Drupal 7, rather than downloading the module Update Notifications Disable because it caused a fatal error, and the site went down. Is there any other ...
2
votes
1answer
4k views

Using field_create_field and field_create_instance to add a checkbox to a content type

I've written the following update hook to add a field to a content type. In an ideal world I'd like that field to be a single on/off checkbox. However, the code I've written outputs three radio ...
0
votes
2answers
156 views

When is a module shown as 'Unsupported' in the list of available updates?

In the available updates, there are few modules with the note unsupported. What does that note actually mean?
2
votes
1answer
149 views

Database updates after pulling in code updates for modules

I've updated a bunch of modules in my local development environment and then committed the code changes using git. On my test site, I've pulled the code and ran drush updb but it's showing that ...
0
votes
1answer
198 views

Core Updates after install with composer create-project drupal/drupal

So I installed Drupal with composer create-project drupal/drupal <...> It works fine, but now I'm trying to update core from 8.4.1 to 8.4.4 What's the right way to do that? composer update ...
1
vote
2answers
46 views

Running 'composer update' replaces module folders

I'm going through the nightmare of trying to update a site to 8.4.4 from 8.3.2. It seems like the best way forward is to delete vendors and composer.lock and let composer replace everything. However, ...
1
vote
0answers
62 views

content_translation_update_8400 causes syntax error

I just tried updating a Drupal v8.3.7 site to v8.4.4 and when running drush updb I get this error SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check ...
0
votes
0answers
1k views

Composer Update failed to execute git diff : error: bad index file sha1 signature

When trying to update drupal 8.4.0 to 8.4.4 I get an error with composer : composer update --with-dependencies Loading composer repositories with package information Updating dependencies (including ...
0
votes
0answers
25 views

How to create a view via hook_update?

I want to create a view via hook_update, looks strange but this is the requirement to bypass allocated memory exhaust error by importing a view. So if view is created by exporting from local instance ...
-1
votes
1answer
1k views

How do I update a module schema?

I have already created a module (test_auth), which I installed on a Drupal site. I added test_auth_schema() & test_auth_update_8101() to test_auth.install. When I run drupal cache:rebuild, it ...
0
votes
1answer
97 views

Error after updating Webform from 8.x-5.0-beta15 to 8.x-5.0-rc1

A Drupal 8 site hosted on Pantheon gives this error message after updating Webform from 8.x-5.0-beta15 to 8.x-5.0-rc1: The website encountered an unexpected error. Please try again later. TypeError: ...
1
vote
1answer
1k views

How do I manually update without using Drush nor Composer?

Is it possible to upgrade Drupal from 8.3.7 to 8.4 without Drush or Composer? Even though I have used composer I am not comfortable with using terminal/console command lines operations. So far used ...
0
votes
1answer
23 views

How to save each array values in next line?

I am having a requirement that, automating the contributed module configurations via hook_update. I have a text area, where i need to mention different URLs with one URL/line. For reference look into ...
-4
votes
1answer
55 views

Will renaming the update.php file affect the Drupal update process?

Will renaming the update.php file affect the Drupal update process? What's the correct way of renaming this file/path? If we want to use /update as alias for a node, there seem to be SEO ...
1
vote
3answers
524 views

Drupal core tries to update to current version

Many sites on my server are running Drupal 7.23, I usually use Drush to update them without any issue. Eveything works fine with modules and themes but Core keeps installing 7.23 on itself. The admin/...
0
votes
2answers
460 views

Entity updates fails after migration D8

So we have taken over a site and I migrated yamlforms to webforms with yamlform_to_webform module using drush. Now when I do a drush updb I get an error that says: The SQL storage cannot change the ...
2
votes
2answers
761 views

Problem updating from Drupal Core 8.3.7 to 8.4.0 with composer

I am having trouble updating from Drupal 8.3.7. When running composer why-not drupal/core 8.4.0 I get the following results: drupal/core 8.4.0 requires symfony/class-loader (~3.2.8) andeersg/bouvet-...
1
vote
1answer
456 views

Core update error

I'm trying to run a composer update from my webroot directory. When I use composer update drupal/core --with-dependencies, it returns: Package "drupal/core" listed for update is not installed. ...
7
votes
4answers
3k views

Right way to update a drupal distribution?

I have a site which is a Commerce Kickstart distribution. My distribution version is 7.x-2.0-rc1 and now the 7.x-2.0-rc2 version is available. How do I update a distribution? I tried these method (...
0
votes
2answers
619 views

Conflict between package requirements when updating to Drupal 8.4

When running composer update, I get the following error: Your requirements could not be resolved to an installable set of packages. Problem 1 - Can only install one of: symfony/yaml[3.2.x-dev, ...
0
votes
1answer
171 views

After updating I got these error messages

After updating my Drupal 8 test site from 8.3.7 to 8.4.0, I got these error messages: Mismatched entity and/or field definitions The following changes were detected in the entity type and field ...
9
votes
4answers
5k views

Updating core from 8.2 to 8.3 via composer

I am trying to update Drupal core to 8.3 but am running into difficulties. At the bottom of the page is the composer.json file I am starting with. If i change "drupal/core": "~8.2" => "drupal/core"...
1
vote
1answer
154 views

Strange symptoms after Drupal 8 core update

I'm new to Drupal 8. After updating D8 Core to 8.3.2 when I try to access Block Configuration Page, I get this error: Symfony\Component\Routing\Exception\RouteNotFoundException: Route "entity.block....
2
votes
2answers
1k views

Rules fatal error during update: Call to undefined method stdClass::events()

What I have tried: Clear Cache. Disabled module and enabled it. Try with registry_rebuild, module_missing_message_fixer, variablecheck modules. Still getting the below error when I try to run update....
1
vote
1answer
4k views

Composer shows “nothing to update” but there is a new version of the module

I am managing a Drupal 8 site in Composer. Commerce 2.0 was just released; I currently have 2.0-rc2 installed on my site. This is my composer.json "drupal/commerce": "^2.0@RC", "minimum-stability":...
0
votes
1answer
1k views

Complicated module update error HTTP error 0 [duplicate]

I'm recently getting the error below: HTTP error 0 occurred when trying to fetch https://ftp.drupal.org/files/projects/captcha-7.x-1.5.tar.gz. Downloading updates failed: Failed to download ...
3
votes
3answers
1k views

How to create a field with hook_update?

I want to create a field with hook_update in my module. I have the following code that creates the configuration for a field_link field: $module_path = drupal_get_path('module', 'my_module'); $...
4
votes
1answer
1k views

How can I upgrade ONLY Drupal core with composer?

I knew that Drush make files were being phased out, but I kept using them, because in my opinion Composer isn't the best package manager in the known universe. It updates too much or too little, has ...
1
vote
1answer
483 views

Adding a new dependency to a module

As a module maintainer, I want to add a dependency to one of my existing modules, so that my entity can use a field type plugin declared by the dependency. What steps do I need to take to make sure ...
1
vote
0answers
240 views

ApcClassLoader.php completely breaks site on module update

I am working on a site that has installs on 3 different environments: a local development copy on a Windows machine, a staging copy on a Linux machine, and a production copy on a Linux machine. All of ...
12
votes
2answers
5k views

Resetting/reverting a custom module's update 'N value'

In my custom module's install file I have a hook_update_N function. Let's say it's mymodule_update_7100. However, I've noticed that I've done it wrong and I want to change a line of code within this ...
11
votes
4answers
2k views

How to rerun hook_post_update_NAME()

Drupal 8 introduced hook_post_update_NAME() which has some benefits over hook_update_n, for updating modules. Each hook_post_update_NAME() should only run once, but sometimes I want to rerun it, like ...
3
votes
1answer
197 views

How do I update Drupal Distribution (Commerce Kickstart) on shared hosting environments?

We currently run a Drupal Commerce site from GoDaddy C-Panel shared hosting environment. I created the site with Commerce Kickstart and am now several distribution updates behind. If that's the ...
0
votes
1answer
763 views

How to update jQuery to version 1.4?

I installed the jQuery Update module, version 6.x-2.0-alpha1, which supports jQuery 1.3.2. I need to update it to jQuery 1.4 or higher, for a jQuery plugin. I tried replacing the existing jquery.js ...
-1
votes
1answer
51 views

Finding out version, and updating to latest stable core version

I have inherited a site that uses Drupal, but I've not had any experience with it before. I'm trying to move it over to a server that has PHP 7 on, but I get all kinds of errors: warning: ...
0
votes
1answer
49 views

Did the updated module actually update?

Just performed an update to Drupal 7.56. In the process I updated all modules, including Google Analytics. The weird thing is that on my machine, where I performed the update, Google Analytics updated ...
1
vote
1answer
701 views

How long will the previous core version supported? [closed]

I want to start a new project at the beginning of 2018 but I don't know if it is better to start this project with Drupal 7 or Drupal 8. Actually, I am not familiar with Drupal 8 coding and template ...
0
votes
2answers
574 views

Core listed as outdated, but composer is not updating it

I'm facing a strange issue with drupal-composer. It has been installed via the usual command line: $ composer create-project drupal-composer/drupal-project:8.x-dev ./ --stability dev --no-interaction ...
0
votes
1answer
2k views

Database updates Out of date

I downloaded a couple of module updates. Before I did so, I didn't disable the modules. Is this ok? I am now seeing the following in my Status Report: Database updates Out of date Some modules ...
2
votes
0answers
28 views

Change of files/image location to a new organized structure [closed]

I would like to clean up safely the existing files Drupal 7 structure and change the location of my existing Files/Image to a new organized structure e.g. in files/content-type/year/node-id Would ...
1
vote
0answers
300 views

Cannot run an update: entity_test module is missing

I've got this error after trying to update to the last Drupal 8 (8.3.2): Drupal\Component\Plugin\Exception\PluginNotFoundException: The "entity_test" entity type does not exist. dans Drupal\Core\...
1
vote
1answer
502 views

Getting configurePhpcs is not callable after update drupal to 8.3.2

I updated drupal with composer composer update Drupal is updated to 8.3.2 but when I install modules I get anytime this message Method Drupal\Core\Composer\Composer::configurePhpcs is not callable, ...
1
vote
0answers
34 views

How do I merge composer manager composer.json with core 8.3 composer.json?

I was using Drupal 8.0.5 site with composer manager. Now I want to upgrade core to 8.3.2 which comes with composer. Composer Manager asked me to uninstall this module, as it is no longer supported ...
0
votes
1answer
59 views

Do I have to update to 8.3.0 first before I can update to latest stable release?

I pritty messed up my site by updating my 8.2.6 site as followed. Step 1: I edit my composer.json file. I replaced the replace to require "replace": { "drupal/core": "~8.3" to "require": { ...
0
votes
1answer
12 views

Disable email updates alert on expired domain

As per question, my domain already expired for over months now and im not planning on using it anymore but i keep getting the modules updates email alert coming from the domain. How can i disable it ...
0
votes
0answers
49 views

How do I get core to detect when a module adds a new service?

I created a module that we are using internally for at least two projects. I pull it in via Composer and it ends up in modules/contrib. The first install went great, but now I have added a few ...
0
votes
1answer
294 views

Is there an automatic way to convert old versioning conventions?

Background I'm applying updates (including security updates) to a Drupal 8 site. Problem When I run composer update, I'm getting the following error multiple times: The requested xxxxx package ...
0
votes
0answers
33 views

Drupal fails to run update.php when new services have been introduced and depend in inactive module

In production environment I have an active module that in a new deployment has changes to the mymodule.services.yml file. This new services file points to services located in an inactive module. I ...

1
3 4
5
6 7
14