Questions tagged [updating]

Use it for questions about updating Drupal core and contributed modules.

Filter by
Sorted by
Tagged with
0
votes
0answers
166 views

Error after updating to latest core version [duplicate]

After Drupalcon last week I felt comfortable using composer, and I was ready to update our site from 8.4.6 to 8.5.1. I have done just that (luckily in a dev environment) and now the front page of the ...
1
vote
0answers
56 views

How to fix getlabel() error?

So I had to update a size of a field and I used an update hook. However, in my update hook I deleted the field and the index and added the field again with the updated size. Now when I go to the ...
2
votes
1answer
245 views

Why doesn't core get updated to 8.5?

I am trying to update via Composer following what reported in Update core via Composer, but when I do composer update drupal/core --with-dependencies, I get the following output. Loading composer ...
0
votes
0answers
70 views

Updated to 8.5.1, but front end says 8.5.0 is installed

I did the update from 8.4.5 to 8.5.x with Composer. I had some issues, but finally got it to work. Now, if I do drush status It says Drupal version : 8.5.1 If I look at the version listed in ...
0
votes
1answer
1k views

drush updb fails with “the 'media_delete_action' plugin does not exist” after 8.4.6 > 8.5.1 update

We have recently updated a Drupal 8.4.6 installation via composer to Drupal 8.5.1. After the composer update I ran drush updb as usual. However, the command fails at one point with the following ...
0
votes
0answers
212 views

Drush silently fails to update core drupal 7 installation - why?

For some reason, drush is reporting successful upgrade of a core Drupal installation from version 7.56 to 7.58, however it is only partially doing the job! See below. Only updates a few files, should ...
1
vote
0answers
170 views

Updated to 8.5.1 but front end still says 8.4.4 installed

I have been going through and updating my drupal sites after the announcement of CVE-2018-7600. All have gone smoothly except for one site that was running Drupal 8.4.4 I updated the site following ...
0
votes
1answer
311 views

How do I fix this update error?

I get the following error after a database update. It looks like it completes the update by displaying Completed 8 of 8 but it doesn't run the updates. Any help is appreciated. Failed: Drupal\...
2
votes
1answer
756 views

Unable to Update to latest core

Update from 8.5.0 to 8.5.1 is failing on one of my drupal instance. >composer update drupal/core --with-dependencies Loading composer repositories with package information Updating dependencies (...
0
votes
1answer
1k views

How do I update core to 8.5?

After I realized that the thing I mostly enjoyed using Drupal for the last 10 years, Drush, is being axed, I started to set up all new Drupal sites with Composer. Unfortunately I can't update core as ...
1
vote
1answer
103 views

What is the best way to update Drupal periodically using a cron job? [closed]

Previously I periodically updated Drupal sites by using a cron-job with a "drush up -y" script running every Wednesday 15,16,17,18,19,20,21,22 hours UTC. which is when "Security releases happen" ...
0
votes
1answer
28 views

Custom Module Remote Fails Checksum with Drush

Background I have several proprietary Drupal modules that my company uses. We want to update these across all our sites. To that end, I've built an endpoint that produces code according to the (ill-...
1
vote
2answers
2k views

The directory tmp does not exist and could not be created

I keep getting this error since updating to Drupal 7.5.8 and cannot get rid of it regardless of trying all I know. Even adding it / copying-pasting the previous tmp dir or changing the tmp file name (...
0
votes
4answers
2k views

How do I update from 8.4.5 to 8.5.0?

I am trying to update Drupal core using Composer, but I am not able of doing it. I have followed a few blog posts, but nothing worked for me. This is the output of composer update drupal/core --with-...
0
votes
1answer
92 views

aborted prematurely while running update #7204 [closed]

I get this message but nothing is logged (that I can see) The update process was aborted prematurely while running update #7204 in wysiwyg.module. All errors have been logged. You may need to check ...
0
votes
0answers
190 views

"The website encountered an unexpected error. (WSOD) Service 'twig_extensions.twig.array' for consumer 'twig'

I have an Acquia Cloud hosted site built on Drupal 8.4.3. Using Acquia Dev Desktop and Drush, I updated a local development environment to Drupal 8.4.5. Immediately after Drush updated the site, I ...
0
votes
1answer
112 views

Error when running database update: “DatabaseSchemaObjectExistsException: Cannot add field redirect.status: field already exists.”

I'm getting the following error when attempting to run a database update: Update #7101 Failed: DatabaseSchemaObjectExistsException: Cannot add field redirect.status: field already exists. in ...
1
vote
1answer
616 views

Unable to run database updates via Drush - Call to undefined function batch_get()

Having some difficulty running database updates via drush after updating modules in the codebase. This is the error that is being reported: Error: Call to undefined function batch_get() in /root/....
1
vote
2answers
81 views

Is it possible to individually update each module using update.php?

I am trying to update the reCAPTCHA module (which is installed on sites/all/modules) in Drupal 7. I could see other 3 modules which have pending updates. Is it possible to individually update each ...
0
votes
0answers
438 views

Enable SFTP for upgrades

After installing D8 on my server, I wanted to add some modules, so I went to Extend / Install new module and was told I needed FTP access to the server. I've got my server configured to only use SFTP,...
0
votes
1answer
162 views

Update problems when updating to Varbase

I updated a Drupal 8 site to Varbase release 16. After running update.php I get the following error. Symfony\Component\Routing\Exception\RouteNotFoundException: Route "content_lock_timeout....
0
votes
1answer
1k views

Composer update : Package “drupal/module_name” listed for update is not installed. Ignoring

After hours of struggling to update Drupal with Composer (see my solution here), I have now some difficulties to update some modules. I was able to update with composer update drupal/bootstrap:3.11 --...
2
votes
2answers
4k views

composer update drupal/drupal does not work : Nothing to install or update

I’ve installed several Drupal 8 site with composer as it is strongly recommended. I can update modules like this : composer require drupal/pathauto:1.1 But I can't update core with composer ...
-2
votes
3answers
505 views

How do I update to latest version? [closed]

I used drupal-composer/drupal-project to install Drupal 8. Drupal 8.4.7 was installed, and the website was functioning as expected. Today, I got the message that Drupal 8.5 was ready for prime time, ...
0
votes
1answer
398 views

Drupal 8 update via drush removes files from vendor folder

I recently made a core update with drush for D8. After the update I saw that it removed a folder from the 'vendor' folder on the server? Why did that happen? The module has been installed via ...
3
votes
1answer
2k views

How to repair “Mismatched entity and/or field definition” when “drush entity-updates” fails?

I'm developing a site in Drupal 8 in Acquia Dev Desktop 2 on Windows 10. After updating to 8.5.0-beta1 I noticed this error on my status page (although it may have been there earlier in 8.4.4): ...
0
votes
2answers
120 views

When is a module shown as 'Unsupported' in the list of available updates?

In the available updates, there are few modules with the note unsupported. What does that note actually mean?
2
votes
1answer
143 views

Database updates after pulling in code updates for modules

I've updated a bunch of modules in my local development environment and then committed the code changes using git. On my test site, I've pulled the code and ran drush updb but it's showing that ...
1
vote
2answers
46 views

Running 'composer update' replaces module folders

I'm going through the nightmare of trying to update a site to 8.4.4 from 8.3.2. It seems like the best way forward is to delete vendors and composer.lock and let composer replace everything. However, ...
0
votes
1answer
195 views

Core Updates after install with composer create-project drupal/drupal

So I installed Drupal with composer create-project drupal/drupal <...> It works fine, but now I'm trying to update core from 8.4.1 to 8.4.4 What's the right way to do that? composer update ...
1
vote
0answers
60 views

content_translation_update_8400 causes syntax error

I just tried updating a Drupal v8.3.7 site to v8.4.4 and when running drush updb I get this error SQLSTATE[42000]: Syntax error or access violation: 1064 You have an error in your SQL syntax; check ...
0
votes
0answers
837 views

Composer Update failed to execute git diff : error: bad index file sha1 signature

When trying to update drupal 8.4.0 to 8.4.4 I get an error with composer : composer update --with-dependencies Loading composer repositories with package information Updating dependencies (including ...
0
votes
0answers
25 views

How to create a view via hook_update?

I want to create a view via hook_update, looks strange but this is the requirement to bypass allocated memory exhaust error by importing a view. So if view is created by exporting from local instance ...
0
votes
1answer
95 views

Error after updating Webform from 8.x-5.0-beta15 to 8.x-5.0-rc1

A Drupal 8 site hosted on Pantheon gives this error message after updating Webform from 8.x-5.0-beta15 to 8.x-5.0-rc1: The website encountered an unexpected error. Please try again later. TypeError: ...
1
vote
1answer
1k views

How do I manually update without using Drush nor Composer?

Is it possible to upgrade Drupal from 8.3.7 to 8.4 without Drush or Composer? Even though I have used composer I am not comfortable with using terminal/console command lines operations. So far used ...
0
votes
1answer
23 views

How to save each array values in next line?

I am having a requirement that, automating the contributed module configurations via hook_update. I have a text area, where i need to mention different URLs with one URL/line. For reference look into ...
0
votes
2answers
409 views

Entity updates fails after migration D8

So we have taken over a site and I migrated yamlforms to webforms with yamlform_to_webform module using drush. Now when I do a drush updb I get an error that says: The SQL storage cannot change the ...
1
vote
1answer
449 views

Core update error

I'm trying to run a composer update from my webroot directory. When I use composer update drupal/core --with-dependencies, it returns: Package "drupal/core" listed for update is not installed. ...
-1
votes
1answer
1k views

How do I update a module schema?

I have already created a module (test_auth), which I installed on a Drupal site. I added test_auth_schema() & test_auth_update_8101() to test_auth.install. When I run drupal cache:rebuild, it ...
-4
votes
1answer
54 views

Will renaming the update.php file affect the Drupal update process?

Will renaming the update.php file affect the Drupal update process? What's the correct way of renaming this file/path? If we want to use /update as alias for a node, there seem to be SEO ...
2
votes
2answers
757 views

Problem updating from Drupal Core 8.3.7 to 8.4.0 with composer

I am having trouble updating from Drupal 8.3.7. When running composer why-not drupal/core 8.4.0 I get the following results: drupal/core 8.4.0 requires symfony/class-loader (~3.2.8) andeersg/bouvet-...
0
votes
2answers
542 views

Conflict between package requirements when updating to Drupal 8.4

When running composer update, I get the following error: Your requirements could not be resolved to an installable set of packages. Problem 1 - Can only install one of: symfony/yaml[3.2.x-dev, ...
0
votes
1answer
168 views

After updating I got these error messages

After updating my Drupal 8 test site from 8.3.7 to 8.4.0, I got these error messages: Mismatched entity and/or field definitions The following changes were detected in the entity type and field ...
2
votes
2answers
1k views

Rules fatal error during update: Call to undefined method stdClass::events()

What I have tried: Clear Cache. Disabled module and enabled it. Try with registry_rebuild, module_missing_message_fixer, variablecheck modules. Still getting the below error when I try ...
1
vote
1answer
3k views

Composer shows “nothing to update” but there is a new version of the module

I am managing a Drupal 8 site in Composer. Commerce 2.0 was just released; I currently have 2.0-rc2 installed on my site. This is my composer.json "drupal/commerce": "^2.0@RC", "minimum-stability":...
0
votes
1answer
170 views

No Available release found

On the module update area, my install of 7.56, can seem to find matches to core and a few modules. How do I begin to fix this? What I've tried so far: Based on translating an answer in Cannot ...
0
votes
1answer
1k views

Complicated module update error HTTP error 0 [duplicate]

I'm recently getting the error below: HTTP error 0 occurred when trying to fetch https://ftp.drupal.org/files/projects/captcha-7.x-1.5.tar.gz. Downloading updates failed: Failed to download ...
0
votes
1answer
417 views

How update programmatically node entity with empty field_image?

i need to make an import from one mysql table in my base. I create node with : $value= array( 'type' => strtolower($typeProduit), 'field_1'=>"test", ...
4
votes
1answer
1k views

How can I upgrade ONLY Drupal core with composer?

I knew that Drush make files were being phased out, but I kept using them, because in my opinion Composer isn't the best package manager in the known universe. It updates too much or too little, has ...
1
vote
1answer
457 views

Adding a new dependency to a module

As a module maintainer, I want to add a dependency to one of my existing modules, so that my entity can use a field type plugin declared by the dependency. What steps do I need to take to make sure ...