Go to `admin/people/permissions` and set the permissions `Translate content` , `Administer content translations` and  `View translation overview assigments`  and you must enable too this permissions for the content type:

    My content type: Create new content 
    My content type: Edit any content