We’re rewarding the question askers & reputations are being recalculated! Read more.

New answers tagged

2

"Drush was unable to query the database" tells you that your issue isn't a missing table, but a configuration issue. You do need to start with an empty but working D8 site before you try running the migration. I'm thinking you didn't initialize your site after downloading the code with composer?


0

You can set the default uri by adding the following file. Then if you don't provide --uri it'll use the default. sites/all/drush/drush.yml options: uri: "https://your-site.domain"


0

Use Drush Luncher it can be easily installed on each linux distributes by : wget -O drush.phar https://github.com/drush-ops/drush-launcher/releases/download/0.6.0/drush.phar chmod +x drush.phar sudo mv drush.phar /usr/bin/drush old method, with using yum sudo yum install https://dl.fedoraproject.org/pub/epel/epel-release-latest-$(rpm -E '%{rhel}')....


0

You will have to give root path and URI in your drush command e.g `drush --root=/path/to/drupal-installation --uri=youdomain.com <command>`


0

On MacOS I found a solution! I has this problem only in the PHPStorm terminal, not in my default MacOS terminal. Solution: use gnu-tar instead of the default one. https://medium.com/@fullsour/installing-gnu-tar-on-mac-827a494b1c1 First how to debug: Not working yet: $ drush dl devel-7.x --destination=modules/ -vvv Outputs a line with "Failed to set ...


0

The output on the screen is caused by a bug in Drush. From https://github.com/drush-ops/drush/issues/4004#issuecomment-479155241: The problem is that Drush is setting tty mode even though output is redirected. This is wrong. Workaround 1 via the command line: drush -Dssh.tty=0 @site.alias sql-dump > ~/Dumps/dumpy.2019-02-19.sql Workaround 2 via the ...


0

I had a similar issue on Windows 10. I didn't notice where the issue was coming from at first because I had Drush installed both globally and locally. After uninstalling drush globally, I noticed drush was not found anymore. After adding my local drush to my PATH I finally managed to launch the site install command.


0

For those who lands here many years later, the same commands for Drush 9 are: drush locale:check drush locale:update


1

I got it working for MySQL with the extra option: $> drush sql-dump --extra="--routines" References: Drush command: https://drushcommands.com/drush-8x/sql/sql-dump/ MySQL dump options: https://dev.mysql.com/doc/refman/5.5/en/mysqldump-stored-programs.html


1

You can login to the Drupal site if you have access to the command line and Drush using the following Drush command $ drush uli username Will give you a URL that you can copy paste into your browser address bar and login as that user. Make sure that you update the domain name to be the same as that of the site. Ref: https://knackforge.com/blog/sivaji/how-...


Top 50 recent answers are included