New answers tagged

0

i solved this by http://willcodeforcoffee.com/2007/01/31/cakephp-error-500-too-many-redirects/ just uncomment or add this: RewriteBase / RewriteEngine On RewriteCond %{REQUEST_FILENAME} !-d RewriteCond %{REQUEST_FILENAME} !-f RewriteRule ^(.*)$ index.php?url=$1 [QSA,L] to your .htaccess file


0

A simple workaround will be to upload the file directly to S3 using AWS CLI. Just in order to create the file in your Drupal database upload a small file with the same name which will later be overwritten by the file you are going to upload using AWS CLI.


2

The s3fs module page mentions the use case of uploading very large files directly to S3: If your users need to upload very large files to your site, you might want to use the S3FS CORS Upload module. It enables CORS-based uploads, allowing files to be uploaded directly to S3, rather than being routed through your server. The s3fs module alone only has a ...


0

// Generate pdf card. $file_path = $crm_card->generatePdfCard(); $filename = basename($file_path); $headers = [ 'Content-Type' => 'application/octet-stream', 'Content-Disposition' => 'attachment; filename="' . $filename . '"', 'Content-Length' => filesize($file_path), ]; $binary_file_response = new BinaryFileResponse($file_path, 200, $...


0

This is a workaround I used to solve the issue: [https://www.drupal.org/project/private_files_download_permission] I don't consider this 'magic' to be a fix. There is a lack of documentation and/or a bug in the filebrowser module. How can one raise an issue with the developers? PS: Also, now have another issue with the filebrowser module: sort order is ...


0

You have to add it to the field type, not entity type. Extend FileItem and override propertyDefinitions() to add it to the field properties. Like the description you've mentioned was added by FileItem extending EntityReferenceItem: /** * {@inheritdoc} */ public static function propertyDefinitions(FieldStorageDefinitionInterface $field_definition) ...


0

So it turns out though I had difficulty understanding them, the directions are "correct". The difficulty I had is partly because of my inexperience, but it's also partly because of a slightly confusing UX in Migrate Drupal UI. The label is asking for your "Public files directory", but what it really wants is your absolute docroot path. The directions state ...


-1

It's my understanding that the 'private' directory can not be used to serve files. The whole point of this special directory is to provide a protected place for the files you choose to place in there. If the images are place in another directory under the 'sites/*/files' directory they should be accessible to be served.


0

I ran into the same problem. I set up the private upload directory like this: $settings['file_private_path'] = $app_root . '/../private'; That way the private folder was above the web root. Although Drupal could access it Webform couldn't. I tried different path levels and ended up with the directory $settings['file_private_path'] = 'sites/default/...


Top 50 recent answers are included