Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

New answers tagged

0

Thanks to what @Cesar Moore said and executing drush locale:check then drush locale:update and drush cr, my translation file is now working for my custom theme too :) FYI : my PO file is in a custom module folder. More refs : https://api.drupal.org/api/drupal/core%21modules%21locale%21locale.api.php/group/interface_translation_properties/8.6.x http://...


0

Turns out this issue was due to my settings on the Detection and selection page at /admin/config/regional/language/detection. I reordered URL to be above User and the translations are now showing. Hopefully, this is able to help someone else in the future.


0

You can look into pathauto.api.php located inside the pathauto module to see which hook suits you best for setting the path programmatically (if this is an option for you). The path can be set or modified per language (which is german and english in this case) like this: \Drupal::service('path.alias_storage')->save("/node/" . $node->id(), '/...


0

In addition to the post of paulcap1 you can look into pathauto.api.php located inside the pathauto module to see which hook suits you best for setting the path programmatically (if this is an option for you). The path can be set or modified per language (which is german and english in this case) like this: \Drupal::service('path.alias_storage')->save("/...


0

Today I had to struggle again with this problem and could solve it by disabling Xdebug. So to sum up this could help: increase memory_limit and max_execution_time update to latest PHP version (at least 7.1) make sure Xdebug is not enabled when saving the settings form (e.g. via browser extension or general xdebug settings on server/vm)


0

The domain associated with each language is stored as configuration. Using the following code, $prefix will contain the prefix, and $domain the domain used. $config = \Drupal::configFactory()->get('language.negotiation'); $languages = \Drupal::languageManager()->getLanguages(); $prefixes = $config->get('url.prefixes'); $domains = $config-&...


Top 50 recent answers are included